summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/rezound
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/rezound')
-rw-r--r--media-sound/rezound/Manifest2
-rw-r--r--media-sound/rezound/files/undefined-functions.patch38
-rw-r--r--media-sound/rezound/metadata.xml12
-rw-r--r--media-sound/rezound/rezound-0.12.3_beta-r2.ebuild86
4 files changed, 138 insertions, 0 deletions
diff --git a/media-sound/rezound/Manifest b/media-sound/rezound/Manifest
new file mode 100644
index 000000000000..8d4af37bee95
--- /dev/null
+++ b/media-sound/rezound/Manifest
@@ -0,0 +1,2 @@
+DIST rezound-0.12.3_beta-patches-6.tar.bz2 14673 SHA256 fd395ba49609e1d4c6e54f291dde2d97b6a8f9ea7905c2428b68a0587bf40f89 SHA512 95b8bd8626b10160e3c74ce75f2ffe675a346f64438df7f3be5cf8b61b0e9b61ba92ec8452406993c3c11adba68d4ac0733eaf43171a535db8c0b3fc2ba606c3 WHIRLPOOL ae6fac793430c3d99fccf583ea22ce68e9647bb285e1dd75131376bed3dc3c1c76654b6db599e0b746bbe6c6e683c1a940dd8619e2cc56fd3d9f09cc6a35f7bc
+DIST rezound-0.12.3beta.tar.gz 1792882 SHA256 9a895f7011048df3485c9ab29b6abf3c4ac8eb4b8842164c42e34b8f0b76426f SHA512 6d043d5fd85ad3b3ea021f62eceeb06064d8f1dc00345bccd7a719c445d5798455b2e014812a99dfd015b4c0d2435c690c98b860efd34ccdfcd5a941b54b7202 WHIRLPOOL db69b0e6ff80c34978d6ea784fdadc2756577f493760cab465d86f4f8c9c360e44e32e73d036f05662afee244cf5053ccb26f8e9f6bb74033da2a0ad1d2aa187
diff --git a/media-sound/rezound/files/undefined-functions.patch b/media-sound/rezound/files/undefined-functions.patch
new file mode 100644
index 000000000000..ef5fbc94e769
--- /dev/null
+++ b/media-sound/rezound/files/undefined-functions.patch
@@ -0,0 +1,38 @@
+--- config/common.h.orig 2004-12-23 20:00:50.710795840 +0100
++++ config/common.h 2004-12-23 20:39:40.271648760 +0100
+@@ -21,6 +21,23 @@
+ #ifndef COMMON_H
+ #define COMMON_H
+
++/* Bugfix for ppc, some functions aren't defined */
++#include <cmath>
++
++#undef MAX
++#define MAX(a,b) ((a) > (b)?(a):(b))
++#undef MIN
++#define MIN(a,b) ((a) < (b)?(a):(b))
++#undef ABS
++#define ABS(a) ((a) >= 0?(a):-(a))
++
++#define floorl(l) floor(l)
++#define nearbyintl(l) nearbyint(l)
++#define fabsl(l) fabs(l)
++#define logl(l) log(l)
++#define expl(l) exp(l)
++#define ceill(l) ceil(l)
++
+ /* common.h -- This file will deal with low-level portability problems. It
+ * should be includede at the top of every package file. */
+
+--- src/frontend_fox/FXWaveCanvas.cpp.orig 2004-12-23 20:18:55.790838600 +0100
++++ src/frontend_fox/FXWaveCanvas.cpp 2004-12-23 20:39:37.568059768 +0100
+@@ -56,6 +56,9 @@
+ #include "../backend/CSoundPlayerChannel.h"
+ #include "drawPortion.h"
+
++#include "../../config/common.h"
++#define max(a,b) MAX(a,b)
++
+ static FXColor playStatusColor=FXRGB(255,0,0);
+
+ #define RIGHT_MARGIN 10
diff --git a/media-sound/rezound/metadata.xml b/media-sound/rezound/metadata.xml
new file mode 100644
index 000000000000..5200ae4c725e
--- /dev/null
+++ b/media-sound/rezound/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <use>
+ <flag name="16bittmp">Use 16bit temporary files (default 32bit float), useful for slower computers</flag>
+ <flag name="soundtouch">compile with support for soundtouch</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">rezound</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild b/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
new file mode 100644
index 000000000000..02ae0ade78e4
--- /dev/null
+++ b/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+MY_P=${P/_/}
+PATCHLEVEL=6
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Sound editor and recorder"
+HOMEPAGE="http://rezound.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc -sparc x86"
+IUSE="16bittmp alsa flac jack nls oss portaudio soundtouch vorbis"
+
+RDEPEND="=sci-libs/fftw-2*
+ >=x11-libs/fox-1.6.19:1.6
+ >=media-libs/audiofile-0.2.3
+ >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15
+ alsa? ( >=media-libs/alsa-lib-1.0 )
+ flac? ( >=media-libs/flac-1.1.2[cxx] )
+ jack? ( media-sound/jack-audio-connection-kit )
+ portaudio? ( >=media-libs/portaudio-18 )
+ soundtouch? ( >=media-libs/libsoundtouch-1.2.1 )
+ vorbis? ( media-libs/libvorbis media-libs/libogg )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ virtual/pkgconfig
+ sys-devel/flex
+ dev-util/reswrap"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ AT_M4DIR="config/m4" eautoreconf
+}
+
+src_configure() {
+ # fix compilation errors on ppc, where some
+ # of the required functions aren't defined
+ use ppc && epatch "${FILESDIR}/undefined-functions.patch"
+
+ # following features can't be disabled if already installed:
+ # -> flac, oggvorbis, soundtouch
+ local sampletype="--enable-internal-sample-type=float"
+ use 16bittmp && sampletype="--enable-internal-sample-type=int16"
+
+ # -O3 isn't safe wrt #275437
+ replace-flags -O[3-9] -O2
+
+ econf \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable portaudio) \
+ $(use_enable flac) \
+ $(use_enable vorbis) \
+ $(use_enable soundtouch) \
+ ${sampletype} \
+ --enable-ladspa \
+ --enable-largefile
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ # remove wrong doc directory
+ rm -rf "${D}/usr/doc"
+
+ dodoc docs/{AUTHORS,NEWS,README*}
+ dodoc docs/{TODO_FOR_USERS_TO_READ,*.txt}
+ newdoc README README.rezound
+
+ docinto code
+ dodoc docs/code/*
+ newicon src/images/icon_logo_32.gif rezound.gif
+ make_desktop_entry rezound Rezound rezound.gif AudioVideo
+}