summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-12-29 09:28:18 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-12-29 09:28:26 +0100
commit273a2ab881f11b1c34d435853a8d0f9c4f049228 (patch)
tree7c41e2707df7ebdf4ac3844daa353728c1ddb7bc /media-sound/qjackctl/qjackctl-0.9.9.ebuild
parentdev-libs/libayatana-appindicator: Keyword 0.5.91 riscv, #887173 (diff)
downloadgentoo-273a2ab881f11b1c34d435853a8d0f9c4f049228.tar.gz
gentoo-273a2ab881f11b1c34d435853a8d0f9c4f049228.tar.bz2
gentoo-273a2ab881f11b1c34d435853a8d0f9c4f049228.zip
media-sound/qjackctl: bump to 0.9.9
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qjackctl/qjackctl-0.9.9.ebuild')
-rw-r--r--media-sound/qjackctl/qjackctl-0.9.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/qjackctl/qjackctl-0.9.9.ebuild b/media-sound/qjackctl/qjackctl-0.9.9.ebuild
new file mode 100644
index 000000000000..127871210489
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.9.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg cmake
+
+DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="https://qjackctl.sourceforge.io/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus debug portaudio"
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ portaudio? ( media-libs/portaudio )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.1-disable-git.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ALSA_SEQ=$(usex alsa 1 0)
+ -DCONFIG_DBUS=$(usex dbus 1 0)
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_PORTAUDIO=$(usex portaudio 1 0)
+ )
+ cmake_src_configure
+}