summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2021-03-17 16:58:47 +0100
committerDaniel Pielmeier <billie@gentoo.org>2021-03-17 16:59:16 +0100
commitcdedadfdcc60f810eb96c3c69f544ad719d0fcf1 (patch)
tree7a729bdc4c70c7ac931d4a106e80cb05b4d250a1 /media-sound/puddletag
parentsys-kernel/gentoo-sources: Linux patch 4.4.262 (diff)
downloadgentoo-cdedadfdcc60f810eb96c3c69f544ad719d0fcf1.tar.gz
gentoo-cdedadfdcc60f810eb96c3c69f544ad719d0fcf1.tar.bz2
gentoo-cdedadfdcc60f810eb96c3c69f544ad719d0fcf1.zip
media-sound/puddletag: Re-add puddletag.
Now supports PyQt5 and python-3. Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'media-sound/puddletag')
-rw-r--r--media-sound/puddletag/Manifest1
-rw-r--r--media-sound/puddletag/metadata.xml19
-rw-r--r--media-sound/puddletag/puddletag-2.0.1.ebuild37
3 files changed, 57 insertions, 0 deletions
diff --git a/media-sound/puddletag/Manifest b/media-sound/puddletag/Manifest
new file mode 100644
index 000000000000..e4833b3a44f9
--- /dev/null
+++ b/media-sound/puddletag/Manifest
@@ -0,0 +1 @@
+DIST puddletag-2.0.1.tar.gz 1227152 BLAKE2B 804e9ca9629a9d78114d6f4b6afbe9032cb414678ea6325679c21ac18867bafed8f1b16aae5fbea18995ecc800d35594c478a5164b377f3b4e5dd75148fd3246 SHA512 d84ba360a6cd8c3ddb6628e30276df58d059d9e8cbb2d1255320ca273436c69f05584059c2e768a15871d3f56dc08d7ac96fef9a9c7c077811bb9fdfde444610
diff --git a/media-sound/puddletag/metadata.xml b/media-sound/puddletag/metadata.xml
new file mode 100644
index 000000000000..7d73860ad35c
--- /dev/null
+++ b/media-sound/puddletag/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>billie@gentoo.org</email>
+ <name>Daniel Pielmeier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <use>
+ <flag name="cover"> Enables editing of FLAC cover art</flag>
+ <flag name="musicbrainz"> Enables support for musicbrainz, needs <pkg>dev-python/python-musicbrainz</pkg></flag>
+ <flag name="quodlibet">Enables support for editing <pkg>media-sound/quodlibet</pkg> databases</flag>
+ <flag name="acoustid">Use <pkg>media-libs/chromaprint</pkg> for acoustic fingerprinting</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">puddletag</remote-id>
+ <remote-id type="github">keithgg/puddletag</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/puddletag/puddletag-2.0.1.ebuild b/media-sound/puddletag/puddletag-2.0.1.ebuild
new file mode 100644
index 000000000000..053f49a198bc
--- /dev/null
+++ b/media-sound/puddletag/puddletag-2.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="Audio tag editor"
+HOMEPAGE="http://docs.puddletag.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acoustid cover musicbrainz quodlibet"
+
+DEPEND=""
+RDEPEND="
+ >=dev-python/configobj-5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.7[${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-5.15.2[${PYTHON_USEDEP},svg]
+ >=media-libs/mutagen-1.45.1[${PYTHON_USEDEP}]
+ acoustid? ( >=media-libs/chromaprint-1.4.3 )
+ quodlibet? ( >=media-sound/quodlibet-4.3.0[${PYTHON_USEDEP}] )
+ >=dev-python/sip-4.19.22:0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.2[${PYTHON_USEDEP}]
+"
+# docs
+# >=dev-python/wheel-0.35.1[${PYTHON_USEDEP}]
+# >=dev-python/markdown-3.1.1[${PYTHON_USEDEP}]
+# >=dev-python/sphinx-1.4.8[${PYTHON_USEDEP}]
+# >=dev-python/sphinx-bootstrap-theme-0.4.13[${PYTHON_USEDEP}]
+# >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
+
+DOCS=(changelog NEWS THANKS TODO)