summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-08 18:54:15 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-08 18:54:15 +0200
commit814404daed8be17f4fa3885112e8d148942cb24b (patch)
treefb56935f06e62449f4a91a22a29831768a231cbc /media-sound/pitchtune/pitchtune-0.0.4.ebuild
parentmedia-sound/gom: Fix building under -fno-common (diff)
downloadgentoo-814404daed8be17f4fa3885112e8d148942cb24b.tar.gz
gentoo-814404daed8be17f4fa3885112e8d148942cb24b.tar.bz2
gentoo-814404daed8be17f4fa3885112e8d148942cb24b.zip
media-sound/pitchtune: Fix building under -fno-common
Closes: https://bugs.gentoo.org/710466 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/pitchtune/pitchtune-0.0.4.ebuild')
-rw-r--r--media-sound/pitchtune/pitchtune-0.0.4.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/media-sound/pitchtune/pitchtune-0.0.4.ebuild b/media-sound/pitchtune/pitchtune-0.0.4.ebuild
index 480bbb1f29df..8cded71773da 100644
--- a/media-sound/pitchtune/pitchtune-0.0.4.ebuild
+++ b/media-sound/pitchtune/pitchtune-0.0.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils
+EAPI=7
+
+inherit autotools desktop
DESCRIPTION="Precise Instrument Tweaking for Crispy Harmony - tuner"
HOMEPAGE="https://sourceforge.net/projects/pitchtune/"
@@ -15,26 +16,24 @@ KEYWORDS="~amd64"
RDEPEND="
dev-libs/glib:2
x11-libs/gtk+:2
- media-libs/alsa-lib
-"
-DEPEND="
- ${RDEPEND}
- sys-devel/gettext
-"
-
-DOCS=( AUTHORS README REQUIRED TODO )
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.0.4-lm.patch
+ "${FILESDIR}"/${PN}-0.0.4-fno-common.patch
)
src_prepare() {
default
-
+ mv configure.{in,ac} || die
eautoreconf
}
src_install() {
default
+ dodoc REQUIRED
doicon pixmaps/${PN}.xpm
make_desktop_entry ${PN} Pitchtune