summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lxmusic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lxmusic')
-rw-r--r--media-sound/lxmusic/Manifest1
-rw-r--r--media-sound/lxmusic/files/lxmusic-0.4.4-libnotify-0.7.patch32
-rw-r--r--media-sound/lxmusic/files/lxmusic-0.4.5-libnotify-0.7.patch27
-rw-r--r--media-sound/lxmusic/lxmusic-0.4.5.ebuild25
-rw-r--r--media-sound/lxmusic/metadata.xml9
5 files changed, 94 insertions, 0 deletions
diff --git a/media-sound/lxmusic/Manifest b/media-sound/lxmusic/Manifest
new file mode 100644
index 000000000000..2d61acb95195
--- /dev/null
+++ b/media-sound/lxmusic/Manifest
@@ -0,0 +1 @@
+DIST lxmusic-0.4.5.tar.gz 288873 SHA256 08a508e1df800f142fef567ff9d3d0e845bfdd70e2edb796b3b7ad0e92dce064
diff --git a/media-sound/lxmusic/files/lxmusic-0.4.4-libnotify-0.7.patch b/media-sound/lxmusic/files/lxmusic-0.4.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..62868c909856
--- /dev/null
+++ b/media-sound/lxmusic/files/lxmusic-0.4.4-libnotify-0.7.patch
@@ -0,0 +1,32 @@
+--- src/lxmusic-notify.c
++++ src/lxmusic-notify.c
+@@ -56,12 +56,26 @@
+ g_return_if_fail (message != NULL);
+
+ lxmusic_clear_notify (n);
+-
+- notify = notify_notification_new (summary, message,
+- "lxmusic", NULL);
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notify = notify_notification_new (summary, message, "lxmusic");
++#else
++ notify = notify_notification_new (summary, message, "lxmusic", NULL);
++#endif
++#else
++ notify = notify_notification_new (summary, message, "lxmusic", NULL);
++#endif
+ n->notification = notify;
+
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++/* lazy */
++#else
++/* lazy */
++#endif
++#else
+ notify_notification_attach_to_status_icon (notify, n->status_icon);
++#endif
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_timeout (notify, NOTIFY_EXPIRES_DEFAULT);
+
diff --git a/media-sound/lxmusic/files/lxmusic-0.4.5-libnotify-0.7.patch b/media-sound/lxmusic/files/lxmusic-0.4.5-libnotify-0.7.patch
new file mode 100644
index 000000000000..01f513de4c3a
--- /dev/null
+++ b/media-sound/lxmusic/files/lxmusic-0.4.5-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+Upstream:
+https://sourceforge.net/tracker/?func=detail&aid=3529198&group_id=180858&atid=894869
+Index: lxmusic-0.4.5/src/lxmusic-notify.c
+===================================================================
+--- lxmusic-0.4.5.orig/src/lxmusic-notify.c
++++ lxmusic-0.4.5/src/lxmusic-notify.c
+@@ -84,9 +84,20 @@ LXMusicNotification lxmusic_do_notify_pr
+ else
+ g_string_append( message, title );
+ struct _LXMusicNotification *lxn = g_new ( struct _LXMusicNotification, 1);
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ lxn->notify = notify_notification_new (summary, message->str, NULL);
++#else
+ lxn->notify = notify_notification_new (summary, message->str, NULL, NULL);
++#endif
++#else
++ lxn->notify = notify_notification_new (summary, message->str, NULL, NULL);
++#endif
+ notify_notification_set_urgency (lxn->notify, NOTIFY_URGENCY_NORMAL);
++#if !defined(NOTIFY_VERSION_MINOR) || (NOTIFY_VERSION_MAJOR == 0 && NOTIFY_VERSION_MINOR < 7)
++ notify_notification_attach_to_status_icon(notify, priv->statusIcon);
+ notify_notification_attach_to_status_icon( lxn->notify, status_icon );
++#endif
+ notify_notification_set_timeout (lxn->notify, NOTIFY_EXPIRES_DEFAULT);
+ g_string_free( message, TRUE );
+ return lxn;
diff --git a/media-sound/lxmusic/lxmusic-0.4.5.ebuild b/media-sound/lxmusic/lxmusic-0.4.5.ebuild
new file mode 100644
index 000000000000..083ef81a2eec
--- /dev/null
+++ b/media-sound/lxmusic/lxmusic-0.4.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A simple GUI XMMS2 client with minimal functionality"
+HOMEPAGE="http://lxde.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ media-sound/xmms2
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
diff --git a/media-sound/lxmusic/metadata.xml b/media-sound/lxmusic/metadata.xml
new file mode 100644
index 000000000000..f8f477c04966
--- /dev/null
+++ b/media-sound/lxmusic/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxde</herd>
+ <longdescription>LXMusic is a simple GUI XMMS2 client with minimal functionality. It can do nothing more than playing music files.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">lxde</remote-id>
+ </upstream>
+</pkgmetadata>