summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-11 15:13:48 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-11 15:13:48 +0200
commitc7899e11fde55834908cdb8dc52aa53e0d511e59 (patch)
tree8e743738e5e9f615469aa914a752fe849458549a /media-sound/grip/grip-3.5.2.ebuild
parentgames-rpg/manaplus: Removed old. (diff)
downloadgentoo-c7899e11fde55834908cdb8dc52aa53e0d511e59.tar.gz
gentoo-c7899e11fde55834908cdb8dc52aa53e0d511e59.tar.bz2
gentoo-c7899e11fde55834908cdb8dc52aa53e0d511e59.zip
media-sound/grip: Bump to version 3.5.2
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'media-sound/grip/grip-3.5.2.ebuild')
-rw-r--r--media-sound/grip/grip-3.5.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/grip/grip-3.5.2.ebuild b/media-sound/grip/grip-3.5.2.ebuild
new file mode 100644
index 000000000000..5f7555472651
--- /dev/null
+++ b/media-sound/grip/grip-3.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs libtool
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ gnome-base/libgnome
+ >=gnome-base/libgnomeui-2.2.0
+ >=media-libs/id3lib-3.8.3
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ >=x11-libs/gtk+-2.2:2
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/vte:0
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ sed '/^Icon/s@grip\b@gripicon@' -i grip.desktop || die
+}
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}