summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-13 00:36:58 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-15 11:56:44 +0200
commit1bd1df57b1bb629d6d180637e3dc346927199252 (patch)
tree2055b340b6e044f349a01d771899f0c4813e7069 /media-sound/gnome-music
parentgnome-extra/nautilus-tracker-tags: version bump 1.10.5 → 1.12.2 (diff)
downloadgentoo-1bd1df57b1bb629d6d180637e3dc346927199252.tar.gz
gentoo-1bd1df57b1bb629d6d180637e3dc346927199252.tar.bz2
gentoo-1bd1df57b1bb629d6d180637e3dc346927199252.zip
media-sound/gnome-music: version bump 3.22.2-r1 → 3.24.2
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'media-sound/gnome-music')
-rw-r--r--media-sound/gnome-music/Manifest1
-rw-r--r--media-sound/gnome-music/gnome-music-3.24.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index 91ddff8a84a7..6f4fe9aaed1b 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1 +1,2 @@
DIST gnome-music-3.22.2.tar.xz 1547556 SHA256 88dc8b6a1d68f07d690ba22d251ac21ba32e7ed948aa3e9f68e9bdc6dfe9674a SHA512 5f30a943209171f19f344139b40725649a56499ad874be138d8681e0ff81fda7fe85fc1b20c3dcf7fea21dd28a0921a47fe28fe064fa1ea8d51a313ec56e7924 WHIRLPOOL 29a7d245841e4be8c91cbe696cd84822ed6993a0838541a1648cbfe4f73034171566d9618d5e240d1261a1e063ee558c70621ee9831fced7923e738466ae4af7
+DIST gnome-music-3.24.2.tar.xz 1557848 SHA256 1a72b7972cac66c7aba7a4fbcbf8df99b3df7c46f26957b3e16089550d3ef62c SHA512 a922c80f922b9231e9bbe0cbd1fd33c059c719350c250dbb24316224e3306de7576303119fc9ec303f569559c36d6b076b5ec1076b4f9221a8fb133dcd9f040e WHIRLPOOL 55c848f0bd99bfbfc2afe1037b53decd13622caf3accac00347653d8295424e28099074eee6c2ec63c3d5cda1bc3e3c54a909a9673d0750f3c25233832b3a3c5
diff --git a/media-sound/gnome-music/gnome-music-3.24.2.ebuild b/media-sound/gnome-music/gnome-music-3.24.2.ebuild
new file mode 100644
index 000000000000..86d2cc46ebc1
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-3.24.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Music"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=app-misc/tracker-1.11.1[introspection(+)]
+ >=dev-python/pygobject-3.21.1:3[cairo,${PYTHON_USEDEP}]
+ >=dev-libs/glib-2.28:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=media-libs/grilo-0.3.2:0.3[introspection]
+ >=media-libs/libmediaart-1.9.1:2.0[introspection]
+ >=x11-libs/gtk+-3.19.3:3[introspection]
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${COMMON_DEPEND}
+ || (
+ app-misc/tracker[gstreamer]
+ app-misc/tracker[ffmpeg]
+ )
+ x11-libs/libnotify[introspection]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.3[tracker]
+ x11-misc/xdg-user-dirs
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.26
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ sed -e '/sys.path.insert/d' -i "${S}"/gnome-music.in || die "python fixup sed failed"
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${D}"usr/bin/gnome-music
+}