summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 15:46:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 17:41:48 +0100
commita166ad1353809d90246f8c1ae490eedd09315bd1 (patch)
treeed8ac4385c33a220ca6699b1e91ab1c41907b879 /media-sound/amsynth
parentmedia-sound/amsynth: Cleanup old/obsolete versions (diff)
downloadgentoo-a166ad1353809d90246f8c1ae490eedd09315bd1.tar.gz
gentoo-a166ad1353809d90246f8c1ae490eedd09315bd1.tar.bz2
gentoo-a166ad1353809d90246f8c1ae490eedd09315bd1.zip
media-sound/amsynth: 1.8.0 version bump, EAPI-7 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/Manifest1
-rw-r--r--media-sound/amsynth/amsynth-1.8.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index 4c9438b1a324..8b08ba29be16 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -1,2 +1,3 @@
DIST amsynth-1.5.1.tar.gz 1297131 BLAKE2B 175c008cd4d7bb45234fa22a31132bcd144df98a3dba34fba3a834ffc8623f52c76b412b3b784cb83ee25d12a8762f62bea8e3488b76039ae64e6a39c4404dbe SHA512 5f1551f9d1398a97738ac6f764f169d8cdd55e94464438adb226d1284fe8845e190fe5dd7a740b33972c1bbe76aa2d60467b7a663ec6717bb9fac75e5aac62d1
DIST amsynth-1.7.1.tar.gz 1409439 BLAKE2B 80fbd2c56b307cb7defce46e2dafe72ce1a56222314faaec9b2d16be9f4412869e377a8cea97d20803eb668b259f2110179607b4148acb8ba7d5e0ef1bb5b14b SHA512 ad5eff805f3ad30a7cc9f3933bbe82b99c670c669c0c405d5045a410afc75cdc0d692856e73ccf870d3ca66e0997a81a5c35baf57b33bb6012f19056cff725c9
+DIST amsynth-1.8.0.tar.bz2 1170068 BLAKE2B 0b570efe1db69bba04215055147792a9635bc086749ca7d70b5b3f8bc16613310591802c6cdabfd83009bda2c3b109b17ccc9d4ace7681614bed8c42c5f84f8d SHA512 a47489b103dbdd1cb2233d8629acfda2a1d26ac1f7ea5b8c4e7925676842cac21758ca94b50894e71426517bd826e9a9b6fd26800516054e24d62f7cbce4f0f9
diff --git a/media-sound/amsynth/amsynth-1.8.0.ebuild b/media-sound/amsynth/amsynth-1.8.0.ebuild
new file mode 100644
index 000000000000..6d3bfcd5b48e
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/amsynth/amsynth"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/release-${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi jack lash oss sndfile"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ >=x11-libs/gtk+-2.20:2
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )
+ sndfile? ( >=media-libs/libsndfile-1:= )
+"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )
+"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with sndfile) \
+ $(use_with dssi)
+}