summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-05-19 10:32:47 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-05-19 10:33:26 +0200
commit96b454efb64c6d396675cda2230a27e982de5a59 (patch)
tree4c5126225630000ec4ea7a9eef2f80185162600a /media-sound/amsynth
parentdev-python/aiodns: Add PROPERTIES=test_network (diff)
downloadgentoo-96b454efb64c6d396675cda2230a27e982de5a59.tar.gz
gentoo-96b454efb64c6d396675cda2230a27e982de5a59.tar.bz2
gentoo-96b454efb64c6d396675cda2230a27e982de5a59.zip
media-sound/amsynth: bump to 1.12.2, updated use flags
Bugs: https://bugs.gentoo.org/740318 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/Manifest1
-rw-r--r--media-sound/amsynth/amsynth-1.12.2.ebuild55
-rw-r--r--media-sound/amsynth/files/amsynth-1.12.2-metadata.patch13
-rw-r--r--media-sound/amsynth/metadata.xml2
4 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index cb833a8f9779..bf4eaad1b432 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -1 +1,2 @@
+DIST amsynth-1.12.2.tar.gz 1607129 BLAKE2B 8308a8a595dfe7b2c9924ff183134fdd5ad20ac2c957b1f52e474a8cb297cd73ee9f8b9938212deb21701e11ccbf776ea22cab763fb71940bf1df5c169e309db SHA512 a1eef3d5a0d0f0ec1edb93d89b3e456ea133a8445a9be73ba338771ae651a2008aea8dd077a9bcf0cd50e6bcc97ad98ab4c44a9baefd9f3381287afdf3325e8f
DIST amsynth-1.8.0.tar.bz2 1170068 BLAKE2B 0b570efe1db69bba04215055147792a9635bc086749ca7d70b5b3f8bc16613310591802c6cdabfd83009bda2c3b109b17ccc9d4ace7681614bed8c42c5f84f8d SHA512 a47489b103dbdd1cb2233d8629acfda2a1d26ac1f7ea5b8c4e7925676842cac21758ca94b50894e71426517bd826e9a9b6fd26800516054e24d62f7cbce4f0f9
diff --git a/media-sound/amsynth/amsynth-1.12.2.ebuild b/media-sound/amsynth/amsynth-1.12.2.ebuild
new file mode 100644
index 000000000000..6afc53191fed
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.12.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/amsynth/amsynth"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi gtk jack lash lv2 nsm oss vst"
+
+REQUIRED_USE="dssi? ( gtk ) lv2? ( gtk )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ )
+ gtk? ( x11-libs/gtk+:2 )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )
+ lv2? ( media-libs/lv2 )
+"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-metadata.patch"
+)
+
+src_configure() {
+ econf \
+ $(use_with alsa) \
+ $(use_with dssi) \
+ $(use_with gtk gui) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with lv2) \
+ $(use_with nsm) \
+ $(use_with oss) \
+ $(use_with vst)
+}
diff --git a/media-sound/amsynth/files/amsynth-1.12.2-metadata.patch b/media-sound/amsynth/files/amsynth-1.12.2-metadata.patch
new file mode 100644
index 000000000000..24b73ea31190
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-1.12.2-metadata.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index e0dd2a6..9bca63f 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1416,7 +1416,7 @@ appiconsvg_DATA = data/icons/scalable/amsynth.svg
+ desktopdir = $(datadir)/applications
+ desktop_in_files = data/amsynth.desktop.in
+ desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+-appdatadir = $(datadir)/appdata
++appdatadir = $(datadir)/metadata
+ appdata_in_files = data/amsynth.appdata.xml.in \
+ data/dssi-amsynth-plugin.metainfo.xml.in \
+ data/lv2-amsynth-plugin.metainfo.xml.in \
diff --git a/media-sound/amsynth/metadata.xml b/media-sound/amsynth/metadata.xml
index 6ac5d966f1b7..a0865e068760 100644
--- a/media-sound/amsynth/metadata.xml
+++ b/media-sound/amsynth/metadata.xml
@@ -8,6 +8,8 @@
<use>
<flag name="dssi">Enable support for DSSI Soft Synth Interface</flag>
<flag name="lv2">Add support for Ladspa V2</flag>
+ <flag name="nsm">Build support for Non Session Manager</flag>
+ <flag name="vst">Build VST plug-in</flag>
</use>
<upstream>
<remote-id type="github">amsynth/amsynth</remote-id>