summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-01-22 09:41:27 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-01-22 09:41:27 +0100
commit11de8095ab63a66ca1a4f378dd66dcd4d9956a3e (patch)
tree7733e9740b9db2ed5861c8b230bc0a2d3b1dc251 /media-sound/amsynth
parentmedia-sound/fapg: bump to 0.44 + eapi8 (diff)
downloadgentoo-11de8095ab63a66ca1a4f378dd66dcd4d9956a3e.tar.gz
gentoo-11de8095ab63a66ca1a4f378dd66dcd4d9956a3e.tar.bz2
gentoo-11de8095ab63a66ca1a4f378dd66dcd4d9956a3e.zip
media-sound/amsynth: bump to 1.13.1
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/Manifest1
-rw-r--r--media-sound/amsynth/amsynth-1.13.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index 871426178e3f..9533d0cea3f7 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -1 +1,2 @@
DIST amsynth-1.13.0.tar.gz 1626209 BLAKE2B 29b79f18ca0ddbba77aaf1bde738f235698f0debe2ddea3b9f2bce2eeaaa399ba125f72b97c83157b87bb28bdb4a259ae2e535c87def16a9e1af3d3093bf0270 SHA512 29698be7d690c76a46a0c8306d6c3b94630b25ed9a3524d7e27d22e244f5c144b74b8473f09eecdb1368443f503ba7024d1c71ead6794f11a2d1cb2114c84bd5
+DIST amsynth-1.13.1.tar.gz 846485 BLAKE2B 32dc7f50a2f5fd7c937c22728fc028f0892f1b76fe613a5fd5025c9c2afe73118e2f661d77668ca3faab691f95ad6c997b7b14b9600f2ca12470c022e4f03860 SHA512 2420edd1c0926c45e86bedc4200b4e39a919e34afc202f0b8c60b172c4f9da5c073305dde006b9e6915ad054c0cfcf259952fa2b8f035378cc04af7fd1bf5c73
diff --git a/media-sound/amsynth/amsynth-1.13.1.ebuild b/media-sound/amsynth/amsynth-1.13.1.ebuild
new file mode 100644
index 000000000000..267958376a56
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.13.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/amsynth/amsynth"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi gtk jack lash lv2 nsm oss vst"
+
+REQUIRED_USE="dssi? ( gtk ) lv2? ( gtk ) vst? ( gtk )"
+
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+RDEPEND="
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ )
+ gtk? (
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )
+ lv2? ( media-libs/lv2 )
+"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12.2-metadata.patch"
+)
+
+src_prepare() {
+ default
+ ! use gtk && eapply "${FILESDIR}/${PN}-1.12.2-x11.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_with alsa) \
+ $(use_with dssi) \
+ $(use_with gtk gui) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with lv2) \
+ $(use_with nsm) \
+ $(use_with oss) \
+ $(use_with vst)
+}