summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /media-libs
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/Field3D/Field3D-1.7.2.ebuild6
-rw-r--r--media-libs/osl/osl-1.10.5.ebuild5
-rw-r--r--media-libs/partio/partio-1.5.4.ebuild6
-rw-r--r--media-libs/partio/partio-9999.ebuild6
-rw-r--r--media-libs/ptex/ptex-2.3.2.ebuild6
5 files changed, 14 insertions, 15 deletions
diff --git a/media-libs/Field3D/Field3D-1.7.2.ebuild b/media-libs/Field3D/Field3D-1.7.2.ebuild
index 4fe5e0457742..4cbf036f9660 100644
--- a/media-libs/Field3D/Field3D-1.7.2.ebuild
+++ b/media-libs/Field3D/Field3D-1.7.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A library for storing voxel data"
HOMEPAGE="http://opensource.imageworks.com/?p=field3d"
@@ -29,7 +29,7 @@ src_configure() {
local mycmakeargs=(
-DINSTALL_DOCS=OFF # Docs are not finished yet.
-DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON
- $(cmake-utils_use_find_package mpi MPI)
+ $(cmake_use_find_package mpi MPI)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/osl/osl-1.10.5.ebuild b/media-libs/osl/osl-1.10.5.ebuild
index c5326986b7a6..190989d2cc9e 100644
--- a/media-libs/osl/osl-1.10.5.ebuild
+++ b/media-libs/osl/osl-1.10.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils llvm toolchain-funcs
+inherit cmake llvm toolchain-funcs
# check this on updates
LLVM_MAX_SLOT=8
@@ -73,7 +73,6 @@ src_configure() {
local gcc=$(tc-getCC)
# LLVM needs CPP11. Do not disable.
local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DENABLERTTI=OFF
-DINSTALL_DOCS=$(usex doc)
-DLLVM_STATIC=ON
@@ -84,5 +83,5 @@ src_configure() {
-DUSE_SIMD="$(IFS=","; echo "${mysimd[*]}")"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/partio/partio-1.5.4.ebuild b/media-libs/partio/partio-1.5.4.ebuild
index 84a164057290..b582c0e424cf 100644
--- a/media-libs/partio/partio-1.5.4.ebuild
+++ b/media-libs/partio/partio-1.5.4.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -35,7 +35,7 @@ DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake_use_find_package doc Doxygen)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/partio/partio-9999.ebuild b/media-libs/partio/partio-9999.ebuild
index 1b109fd6da7f..5404d30fd501 100644
--- a/media-libs/partio/partio-9999.ebuild
+++ b/media-libs/partio/partio-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -35,7 +35,7 @@ DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake_use_find_package doc Doxygen)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-libs/ptex/ptex-2.3.2.ebuild b/media-libs/ptex/ptex-2.3.2.ebuild
index 48580481fd2b..20e552cd3441 100644
--- a/media-libs/ptex/ptex-2.3.2.ebuild
+++ b/media-libs/ptex/ptex-2.3.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
HOMEPAGE="http://ptex.us/"
@@ -27,7 +27,7 @@ src_prepare() {
cat <<-EOF > version || die
${PV}
EOF
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -35,5 +35,5 @@ src_configure() {
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html"
-DPTEX_BUILD_STATIC_LIBS=$(usex static-libs)
)
- cmake-utils_src_configure
+ cmake_src_configure
}