summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-16 20:18:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-16 20:29:15 +0100
commit8f8e4d3a59037e34ed579e70ea9651fcbbd6836a (patch)
tree3f023fa464362b6a8a3ae502b37e0c3b14e42756 /media-libs
parentmedia-libs/phonon: Fix PulseAudio support with Qt 5.12, EAPI-7 bump (diff)
downloadgentoo-8f8e4d3a59037e34ed579e70ea9651fcbbd6836a.tar.gz
gentoo-8f8e4d3a59037e34ed579e70ea9651fcbbd6836a.tar.bz2
gentoo-8f8e4d3a59037e34ed579e70ea9651fcbbd6836a.zip
media-libs/phonon-vlc: Disable vlc screensaver inhibitor, EAPI-7 bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/phonon-vlc/files/phonon-vlc-0.10.1-screensaver-inhibitor.patch31
-rw-r--r--media-libs/phonon-vlc/phonon-vlc-0.10.1-r1.ebuild45
-rw-r--r--media-libs/phonon-vlc/phonon-vlc-9999.ebuild7
3 files changed, 80 insertions, 3 deletions
diff --git a/media-libs/phonon-vlc/files/phonon-vlc-0.10.1-screensaver-inhibitor.patch b/media-libs/phonon-vlc/files/phonon-vlc-0.10.1-screensaver-inhibitor.patch
new file mode 100644
index 000000000000..1e482a027e52
--- /dev/null
+++ b/media-libs/phonon-vlc/files/phonon-vlc-0.10.1-screensaver-inhibitor.patch
@@ -0,0 +1,31 @@
+From cb7c2b74b25380b49b2bb7bbfb7ac3fb37f1cd28 Mon Sep 17 00:00:00 2001
+From: Harald Sitter <sitter@kde.org>
+Date: Tue, 9 Oct 2018 13:22:30 +0200
+Subject: disable the builtin vlc screen saver inhibitor
+
+from a phonon perspective we expect the application to inhibit.
+additionally destructing a player may attempt to uninhibit and block
+on dbus not responding because the call is too late in the lifecycle or
+to an unresponsive remote (all of which the app would ordinarily
+deal with)
+---
+ src/utils/libvlc.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/utils/libvlc.cpp b/src/utils/libvlc.cpp
+index 39e831c..3a33d9a 100644
+--- a/src/utils/libvlc.cpp
++++ b/src/utils/libvlc.cpp
+@@ -90,6 +90,10 @@ bool LibVLC::init()
+ args << "--no-xlib";
+ // Do not preload services discovery modules, we don't use them.
+ args << "--services-discovery=''";
++ // The application is meant to manage this. Also, using the builtin
++ // inhibitor may cause problems on shutdown if VLC tries to uninhibit too
++ // late in the application lifecycle.
++ args << "--no-disable-screensaver";
+ // Allow multiple starts (one gets to wonder whether that makes a difference).
+ #if !defined(Q_OS_MAC) && (defined(Q_OS_WIN) || !defined(PHONON_NO_DBUS))
+ args << "--no-one-instance";
+--
+cgit v1.1
diff --git a/media-libs/phonon-vlc/phonon-vlc-0.10.1-r1.ebuild b/media-libs/phonon-vlc/phonon-vlc-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..9c4a65c67546
--- /dev/null
+++ b/media-libs/phonon-vlc/phonon-vlc-0.10.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="phonon-backend-vlc"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+else
+ EGIT_REPO_URI=( "git://anongit.kde.org/${PN}" )
+ inherit git-r3
+fi
+
+inherit cmake-utils
+
+DESCRIPTION="Phonon VLC backend"
+HOMEPAGE="https://phonon.kde.org/"
+
+LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=media-libs/phonon-4.10.0
+ media-video/vlc:=[dbus,ogg,vorbis]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-qt-5.11.patch"
+ "${FILESDIR}/${P}-screensaver-inhibitor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=( -DPHONON_BUILD_PHONON4QT5=ON )
+ cmake-utils_src_configure
+}
diff --git a/media-libs/phonon-vlc/phonon-vlc-9999.ebuild b/media-libs/phonon-vlc/phonon-vlc-9999.ebuild
index 18a2f10173c6..0cf441288e15 100644
--- a/media-libs/phonon-vlc/phonon-vlc-9999.ebuild
+++ b/media-libs/phonon-vlc/phonon-vlc-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_PN="phonon-backend-vlc"
@@ -29,7 +29,8 @@ RDEPEND="
>=media-libs/phonon-4.10.0
media-video/vlc:=[dbus,ogg,vorbis]
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
"