summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-10-22 09:33:27 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-10-22 09:39:48 -0400
commit739ff8773274767c6bfea15b021da195f3635564 (patch)
tree78871cdec19b880b136b008ae9d5028a2c136af6 /media-libs
parentdev-python/a2wsgi: Enable tests using starlette (diff)
downloadgentoo-739ff8773274767c6bfea15b021da195f3635564.tar.gz
gentoo-739ff8773274767c6bfea15b021da195f3635564.tar.bz2
gentoo-739ff8773274767c6bfea15b021da195f3635564.zip
media-libs/libplacebo: fix build with glslang-1.3.296.0
Tempting to just drop support for using glslang directly given that package changes things around all the time while shaderc wraps around these changes for us. It's also what upstream defaults to. Albeit does require keywording shaderc on more arches if going for that (aka arm64 for one wrt bug #941968). Closes: https://bugs.gentoo.org/941968 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libplacebo/files/libplacebo-7.349.0-glslang-1.3.296.patch16
-rw-r--r--media-libs/libplacebo/libplacebo-7.349.0.ebuild1
-rw-r--r--media-libs/libplacebo/libplacebo-9999.ebuild1
3 files changed, 18 insertions, 0 deletions
diff --git a/media-libs/libplacebo/files/libplacebo-7.349.0-glslang-1.3.296.patch b/media-libs/libplacebo/files/libplacebo-7.349.0-glslang-1.3.296.patch
new file mode 100644
index 000000000000..81af061634b5
--- /dev/null
+++ b/media-libs/libplacebo/files/libplacebo-7.349.0-glslang-1.3.296.patch
@@ -0,0 +1,16 @@
+Quick workaround for libSPIRV seemingly having became a stub in glslang-1.3.296
+
+https://bugs.gentoo.org/941968
+
+TODO?: rather than worry with the constant issues with glslang, should likely
+always force shaderc -- it's also what upstream prefers by default and so the
+glslang paths are hardly tested.
+--- a/src/glsl/meson.build
++++ b/src/glsl/meson.build
+@@ -39,4 +39,5 @@
+
+ glslang_deps += spirv
++ glslang_deps += cxx.find_library('glslang', required: required, static: static)
+
+ if static
+
diff --git a/media-libs/libplacebo/libplacebo-7.349.0.ebuild b/media-libs/libplacebo/libplacebo-7.349.0.ebuild
index 9d16436f4759..7899dff069c5 100644
--- a/media-libs/libplacebo/libplacebo-7.349.0.ebuild
+++ b/media-libs/libplacebo/libplacebo-7.349.0.ebuild
@@ -71,6 +71,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-5.229.1-llvm-libunwind.patch
"${FILESDIR}"/${PN}-5.229.1-python-executable.patch
+ "${FILESDIR}"/${PN}-7.349.0-glslang-1.3.296.patch
)
python_check_deps() {
diff --git a/media-libs/libplacebo/libplacebo-9999.ebuild b/media-libs/libplacebo/libplacebo-9999.ebuild
index 1831a83708b6..ecef342f645d 100644
--- a/media-libs/libplacebo/libplacebo-9999.ebuild
+++ b/media-libs/libplacebo/libplacebo-9999.ebuild
@@ -71,6 +71,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-5.229.1-llvm-libunwind.patch
"${FILESDIR}"/${PN}-5.229.1-python-executable.patch
+ "${FILESDIR}"/${PN}-7.349.0-glslang-1.3.296.patch
)
python_check_deps() {