summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-14 16:48:43 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-14 16:59:19 +0100
commit3da3adbf0f1c3c950114c22ba22db5646f03709a (patch)
treeb846b470f2e5c9adb042ca6a6614f59501b6a3cc /media-libs
parentmedia-libs/taglib: ia64 stable wrt bug #700054 (diff)
downloadgentoo-3da3adbf0f1c3c950114c22ba22db5646f03709a.tar.gz
gentoo-3da3adbf0f1c3c950114c22ba22db5646f03709a.tar.bz2
gentoo-3da3adbf0f1c3c950114c22ba22db5646f03709a.zip
media-libs/gegl: Use upstream CPU detection patch
Bug: https://bugs.gentoo.org/698744 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gegl/files/gegl-0.4.18-arch.patch11
-rw-r--r--media-libs/gegl/files/gegl-0.4.18-meson_cpu_detection.patch51
-rw-r--r--media-libs/gegl/gegl-0.4.18.ebuild2
3 files changed, 52 insertions, 12 deletions
diff --git a/media-libs/gegl/files/gegl-0.4.18-arch.patch b/media-libs/gegl/files/gegl-0.4.18-arch.patch
deleted file mode 100644
index 57bfaf4a6c73..000000000000
--- a/media-libs/gegl/files/gegl-0.4.18-arch.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -88,8 +88,6 @@
- have_ppc = true
- config.set10('ARCH_PPC', true)
- config.set10('ARCH_PPC64', true)
--else
-- error('Unknown host architecture')
- endif
-
- ################################################################################
diff --git a/media-libs/gegl/files/gegl-0.4.18-meson_cpu_detection.patch b/media-libs/gegl/files/gegl-0.4.18-meson_cpu_detection.patch
new file mode 100644
index 000000000000..7f6b3624f361
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.4.18-meson_cpu_detection.patch
@@ -0,0 +1,51 @@
+From 6bcf95fd0f32cf5e8b1ddbe17b14d9ad049bded8 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Sun, 27 Oct 2019 14:10:08 +0100
+Subject: [PATCH] meson: fix cpu detection
+
+Use host_machine.cpu_family() instead of cpu(). Only the former
+provides a stable/defined set of values.
+
+Also don't error out on some arches for no good reason.
+
+This fixes the build on 32bit Windows.
+---
+ meson.build | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index af133a0f1..540498921 100644
+--- a/meson.build
++++ b/meson.build
+@@ -73,23 +73,21 @@ if os_osx and cc.get_id() != 'clang'
+ endif
+
+
+-host_cpu = host_machine.cpu()
+-if host_cpu.startswith('i') and host_cpu.endswith('86')
++host_cpu_family = host_machine.cpu_family()
++if host_cpu_family == 'x86'
+ have_x86 = true
+ config.set10('ARCH_X86', true)
+-elif host_cpu == 'x86_64'
++elif host_cpu_family == 'x86_64'
+ have_x86 = true
+ config.set10('ARCH_X86', true)
+ config.set10('ARCH_X86_64', true)
+-elif host_cpu == 'ppc' or host_cpu == 'powerpc'
++elif host_cpu_family == 'ppc'
+ have_ppc = true
+ config.set10('ARCH_PPC', true)
+-elif host_cpu == 'ppc64' or host_cpu == 'powerpc64'
++elif host_cpu_family == 'ppc64'
+ have_ppc = true
+ config.set10('ARCH_PPC', true)
+ config.set10('ARCH_PPC64', true)
+-else
+- error('Unknown host architecture')
+ endif
+
+ ################################################################################
+--
+2.22.0
+
diff --git a/media-libs/gegl/gegl-0.4.18.ebuild b/media-libs/gegl/gegl-0.4.18.ebuild
index 7de01528fc40..f23c5220119d 100644
--- a/media-libs/gegl/gegl-0.4.18.ebuild
+++ b/media-libs/gegl/gegl-0.4.18.ebuild
@@ -80,7 +80,7 @@ DOCS=( AUTHORS docs/ChangeLog docs/NEWS.txt )
PATCHES=(
"${FILESDIR}"/${PN}-0.4.18-drop-failing-tests.patch
"${FILESDIR}"/${PN}-0.4.18-program-suffix.patch
- "${FILESDIR}"/${PN}-0.4.18-arch.patch
+ "${FILESDIR}"/${P}-meson_cpu_detection.patch
)
pkg_setup() {