summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-25 17:40:35 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-25 18:05:03 +0200
commit20c16061a5beacf338203117ee02f204c4689c1e (patch)
tree3f6331ac548232591923af82d867f215c1227aea /media-libs
parentmedia-libs/mutagen: cleanup doc generation (diff)
downloadgentoo-20c16061a5beacf338203117ee02f204c4689c1e.tar.gz
gentoo-20c16061a5beacf338203117ee02f204c4689c1e.tar.bz2
gentoo-20c16061a5beacf338203117ee02f204c4689c1e.zip
media-libs/mutagen: clean tests
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20984 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mutagen/mutagen-1.45.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/media-libs/mutagen/mutagen-1.45.1.ebuild b/media-libs/mutagen/mutagen-1.45.1.ebuild
index bc580066567e..6c482da9106b 100644
--- a/media-libs/mutagen/mutagen-1.45.1.ebuild
+++ b/media-libs/mutagen/mutagen-1.45.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
@@ -13,25 +13,24 @@ SRC_URI="https://github.com/quodlibet/mutagen/releases/download/release-${PV}/${
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-# TODO: Missing support for >=dev-python/eyeD3-0.7 API
-# test? ( >=dev-python/eyeD3-0.7 )
BDEPEND="
test? (
+ dev-python/eyeD3[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
-RESTRICT="!test? ( test )"
-
DOCS=( NEWS README.rst )
+distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme
python_test() {
- esetup.py test --no-quality
+ local deselect=(
+ tests/quality/test_flake8.py
+ )
+ epytest ${deselect[@]/#/--deselect }
}