summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-11-14 14:19:49 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-11-14 14:21:41 +0100
commit1db29ed4fa20a3cb890cc5d078ad7a348376f13d (patch)
tree89a9a85cfe05be926dbf30349c5c40ccb3d976d6 /media-libs
parentnet-proxy/squid: bump to 4.17 (diff)
downloadgentoo-1db29ed4fa20a3cb890cc5d078ad7a348376f13d.tar.gz
gentoo-1db29ed4fa20a3cb890cc5d078ad7a348376f13d.tar.bz2
gentoo-1db29ed4fa20a3cb890cc5d078ad7a348376f13d.zip
Revert "media-libs/codec2: removed obsolete 1.0.0"
This reverts commit 7c5826792ef6245f1bc46e905eaab988982b698a. Bug: https://bugs.gentoo.org/816453 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/codec2/Manifest1
-rw-r--r--media-libs/codec2/codec2-1.0.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/codec2/Manifest b/media-libs/codec2/Manifest
index 824a9b22757c..b4448103a0d7 100644
--- a/media-libs/codec2/Manifest
+++ b/media-libs/codec2/Manifest
@@ -1 +1,2 @@
+DIST codec2-1.0.0.tar.gz 15019266 BLAKE2B fa33a8c30a7472e5f5ab0aac070431579913248d9d27cbc82542b6d7071f7a9fee6bafe374300bf6e09d636b9ddaf85795aabf12cbfd3923efd0cac82f06b38c SHA512 bba8ccf915600b093252c85059c5472804e843f5a4e331cc6e01f31b4131d84362d8385d0a1d8703be36064ca498e58181c2b7fdedb76d0be58bf6f13ec929b3
DIST codec2-1.0.1.tar.gz 15062219 BLAKE2B 81f2784d7aa7180fcc4345fd27e7dd0beda0eba3bbee43d8379a48dc854fe1c9e50038c90c9ae41daacb5aef0f337841fa64ce061e2831523a71d5d52d1b8211 SHA512 e32b6ebb5480b4a6ae15e835abc0da4fac7fb46a2b14bcc2a3c52df2da6c8d3f5acbcf83d8039f1ee402b4d2e1e7445841e3c9c415bfb70af3a251e74ab3f3b6
diff --git a/media-libs/codec2/codec2-1.0.0.ebuild b/media-libs/codec2/codec2-1.0.0.ebuild
new file mode 100644
index 000000000000..f9d617bb6115
--- /dev/null
+++ b/media-libs/codec2/codec2-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Low bit rate speech codec"
+HOMEPAGE="https://freedv.org/ https://www.rowetel.com/?page_id=452 https://github.com/drowe67/codec2"
+SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="examples test"
+# Not yet passing, but infrastructure added to run
+RESTRICT="test"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUNITTEST=$(usex test)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ )
+ cmake_src_configure
+}