summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-09-05 16:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-09-05 14:54:13 -0400
commit295166a86e96aef23f9cc311e71eb29556aaeaa4 (patch)
tree7759ce8603a422f8448dd1a2b83feb16a5f4c80f /media-libs/x264/x264-0.0.20190903-r1.ebuild
parentdev-perl/File-Slurper: Bump to version 0.12.0 (diff)
downloadgentoo-295166a86e96aef23f9cc311e71eb29556aaeaa4.tar.gz
gentoo-295166a86e96aef23f9cc311e71eb29556aaeaa4.tar.bz2
gentoo-295166a86e96aef23f9cc311e71eb29556aaeaa4.zip
media-libs/x264: Set special value of AS to fix build failure.
Closes: https://bugs.gentoo.org/721026 Closes: https://bugs.gentoo.org/724676 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'media-libs/x264/x264-0.0.20190903-r1.ebuild')
-rw-r--r--media-libs/x264/x264-0.0.20190903-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/media-libs/x264/x264-0.0.20190903-r1.ebuild b/media-libs/x264/x264-0.0.20190903-r1.ebuild
index e65caa445b83..453ed7982ff2 100644
--- a/media-libs/x264/x264-0.0.20190903-r1.ebuild
+++ b/media-libs/x264/x264-0.0.20190903-r1.ebuild
@@ -34,6 +34,13 @@ PATCHES=("${FILESDIR}"/${P}-STRINGS.patch)
multilib_src_configure() {
tc-export CC
+
+ if [[ ${ABI} == x86 || ${ABI} == amd64 ]]; then
+ export AS="nasm"
+ else
+ export AS="${CC}"
+ fi
+
local asm_conf=""
if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !cpu_flags_ppc_altivec ; }; then