summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-23 21:43:45 +0100
committerSam James <sam@gentoo.org>2022-05-23 21:44:08 +0100
commitde20312c7cc3c05ec8183595808198048699fed2 (patch)
tree973587b4fecc4d3e2e1c8423778820b5a20d8284 /media-libs/openjpeg
parentprofiles: Mask gnome-extra/gnome-documents for removal (diff)
downloadgentoo-de20312c7cc3c05ec8183595808198048699fed2.tar.gz
gentoo-de20312c7cc3c05ec8183595808198048699fed2.tar.bz2
gentoo-de20312c7cc3c05ec8183595808198048699fed2.zip
media-libs/openjpeg: fix GNUInstallDirs patch
- Fix install dir for CMake*Config (needs to be in a subdir) - Fix include path within those Closes: https://bugs.gentoo.org/847013 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/openjpeg')
-rw-r--r--media-libs/openjpeg/files/openjpeg-2.5.0-gnuinstalldirs.patch33
-rw-r--r--media-libs/openjpeg/openjpeg-2.5.0-r2.ebuild (renamed from media-libs/openjpeg/openjpeg-2.5.0-r1.ebuild)0
2 files changed, 26 insertions, 7 deletions
diff --git a/media-libs/openjpeg/files/openjpeg-2.5.0-gnuinstalldirs.patch b/media-libs/openjpeg/files/openjpeg-2.5.0-gnuinstalldirs.patch
index f47f062b8939..9e0eebbfdfb7 100644
--- a/media-libs/openjpeg/files/openjpeg-2.5.0-gnuinstalldirs.patch
+++ b/media-libs/openjpeg/files/openjpeg-2.5.0-gnuinstalldirs.patch
@@ -75,7 +75,7 @@ Raises minimum cmake version by a little.
- # hardcoded path to libraries on a multi-arch system (fedora/debian) those
- # path will be different (lib/i386-linux-gnu vs lib/x86_64-linux-gnu)
- set(OPENJPEG_INSTALL_PACKAGE_DIR "${OPENJPEG_INSTALL_LIB_DIR}/${OPENJPEG_INSTALL_SUBDIR}")
-+ set(OPENJPEG_INSTALL_PACKAGE_DIR "${CMAKE_INSTALL_LIBDIR}/cmake/${CMAKE_INSTALL_SUBDIR}")
++ set(OPENJPEG_INSTALL_PACKAGE_DIR "${CMAKE_INSTALL_LIBDIR}/cmake/${OPENJPEG_INSTALL_SUBDIR}")
endif()
if (APPLE)
@@ -120,19 +120,38 @@ Raises minimum cmake version by a little.
endif()
endif()
+@@ -385,3 +346,14 @@ endif()
+
+ # build our version of astyle
+ SET (WITH_ASTYLE FALSE CACHE BOOL "If you plan to contribute you should reindent with scripts/prepare-commit.sh (using 'our' astyle)")
++
++message(STATUS "<<< Gentoo configuration >>>
++Build type ${CMAKE_BUILD_TYPE}
++Install path ${CMAKE_INSTALL_PREFIX}
++Compiler flags:
++C ${CMAKE_C_FLAGS}
++C++ ${CMAKE_CXX_FLAGS}
++Linker flags:
++Executable ${CMAKE_EXE_LINKER_FLAGS}
++Module ${CMAKE_MODULE_LINKER_FLAGS}
++Shared ${CMAKE_SHARED_LINKER_FLAGS}\n")
--- a/cmake/OpenJPEGConfig.cmake.in
+++ b/cmake/OpenJPEGConfig.cmake.in
-@@ -28,8 +28,8 @@ if(EXISTS ${SELF_DIR}/OpenJPEGTargets.cmake)
+@@ -27,12 +27,8 @@ if(EXISTS ${SELF_DIR}/OpenJPEGTargets.cmake)
+ # This is an install tree
include(${SELF_DIR}/OpenJPEGTargets.cmake)
- # We find a relative path from the PKG directory to header files.
+- # We find a relative path from the PKG directory to header files.
- set(PKG_DIR "@CMAKE_INSTALL_PREFIX@/@OPENJPEG_INSTALL_PACKAGE_DIR@")
- set(INC_DIR "@CMAKE_INSTALL_PREFIX@/@OPENJPEG_INSTALL_INCLUDE_DIR@")
-+ set(PKG_DIR "@CMAKE_INSTALL_FULL_INCLUDEDIR@/@OPENJPEG_INSTALL_PACKAGE_DIR@")
-+ set(INC_DIR "@CMAKE_INSTALL_FULL_INCLUDEDIR@/@OPENJPEG_INSTALL_INCLUDE_DIR@")
- file(RELATIVE_PATH PKG_TO_INC_RPATH "${PKG_DIR}" "${INC_DIR}")
+- file(RELATIVE_PATH PKG_TO_INC_RPATH "${PKG_DIR}" "${INC_DIR}")
+-
+- get_filename_component(OPENJPEG_INCLUDE_DIRS "${SELF_DIR}/${PKG_TO_INC_RPATH}" REALPATH)
++ set(INC_DIR "@CMAKE_INSTALL_FULL_INCLUDEDIR@/@OPENJPEG_INSTALL_SUBDIR@")
++ get_filename_component(OPENJPEG_INCLUDE_DIRS "${INC_DIR}" ABSOLUTE)
- get_filename_component(OPENJPEG_INCLUDE_DIRS "${SELF_DIR}/${PKG_TO_INC_RPATH}" REALPATH)
+ else()
+ if(EXISTS ${SELF_DIR}/OpenJPEGExports.cmake)
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -44,7 +44,7 @@ if(DOXYGEN_FOUND)
diff --git a/media-libs/openjpeg/openjpeg-2.5.0-r1.ebuild b/media-libs/openjpeg/openjpeg-2.5.0-r2.ebuild
index 70cd86a4a35c..70cd86a4a35c 100644
--- a/media-libs/openjpeg/openjpeg-2.5.0-r1.ebuild
+++ b/media-libs/openjpeg/openjpeg-2.5.0-r2.ebuild