summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-07-14 15:30:52 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-07-14 15:31:18 -0400
commit58b7ccd4efe36912ad3cf661ba872d94f2bbeed1 (patch)
treefc0b37dfd8824a642a6fdc284f9264a0d88b6786 /media-libs/openh264/files
parentsci-geosciences/opencpn: bump version, fix bug #623838 (diff)
downloadgentoo-58b7ccd4efe36912ad3cf661ba872d94f2bbeed1.tar.gz
gentoo-58b7ccd4efe36912ad3cf661ba872d94f2bbeed1.tar.bz2
gentoo-58b7ccd4efe36912ad3cf661ba872d94f2bbeed1.zip
media-libs/openh264: version bump to 1.7.0
Upstream release notes courtesy the gentoo bug below: - Changed SPS/PPS strategy option name,See enum ENCODER_OPTION - Changed NAL size length parameter from static array to pointer to support more NALs.See struct SParserBsInfo - Changed semaphores to condition variables on apple platform - Changed version update mechanism as Major.Minor.patch,like 1.7.0 - Supported to force IDR independently for each layer in simulcast AVC case.See API ForceIntraFrame() - Supported LTR request independently for each layer in simulcast AVC case. See struct SLTRRecoverRequest and SLTRMarkingFeedback - Supported to set sample aspect ratio in VUI on encoder side. See struct SSpatialLayerConfig - Supported to set profile and level, changed the default level as 4.1 if the user doesn’t set it. See enum ELevelIdc - Supported to get profile and level info on decoder side.See enum DECODER_OPTION - Supported for enable/disable AVX2 build option. Build option: HAVE_AVX2 - Supported to set decoder statistics log interval, Add DECODER_OPTION_STATISTICS_LOG_INTERVAL.See DECODER_OPTION. - Supported for AU delimiter NAL on decoder side. AU delimiter refers to section 7.3.2.4 - Supported for x86 PIC assembly and build option. Build option: ENABLEPIC. git issues:#2263 #2534 - Supported for Cygwin x86_64 build - Supported to get sample aspect ratio by GetOption on decoder. Add option: DECODER_OPTION_GET_SAR_INFO - Set constraint_set4_flag constraint_set5_flag to align to CHP definition in latest H264 standard - Improved VUI support on decoder side - Improved decoder statistics info output - Refined the return value when failed in memory allocation - Added SSSE3 motion compensation routines - Added AVX2 motion compensation routines - Optimization on some of SSE2/MMX functions - Refactor rate control for RC_BUFFERBASED_MODE and RC_QUALITY_MODE mode - Added more unit tests for random resolution input,slice mode switch, profile/level setting - Refined logs - Bug fixes for 4:0:0 format support on decoder - Bug fixes for complexity calculation for screen content mode - Bug fixes for loadbalancing turn on, git issue:#2618 - Bug fixes for parser subsps, scalling list, parser longer bitstream Bug: http://bugs.gentoo.org/622170 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-libs/openh264/files')
-rw-r--r--media-libs/openh264/files/openh264-1.7.0-pkgconfig-pathfix.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/openh264/files/openh264-1.7.0-pkgconfig-pathfix.patch b/media-libs/openh264/files/openh264-1.7.0-pkgconfig-pathfix.patch
new file mode 100644
index 000000000000..b0813888477a
--- /dev/null
+++ b/media-libs/openh264/files/openh264-1.7.0-pkgconfig-pathfix.patch
@@ -0,0 +1,40 @@
+--- a/openh264.pc.in 2015-10-19 21:49:05.000000000 -0400
++++ b/openh264.pc.in 2016-02-17 12:17:03.792768147 -0500
+@@ -1,6 +1,6 @@
+ prefix=@prefix@
+-libdir=${prefix}/lib
+-includedir=${prefix}/include
++libdir=@sharedlibdir@
++includedir=@includesdir@
+
+ Name: OpenH264
+ Description: OpenH264 is a codec library which supports H.264 encoding and decoding. It is suitable for use in real time applications such as WebRTC.
+--- a/Makefile 2017-06-16 00:20:14.000000000 -0400
++++ b/Makefile 2017-07-14 15:15:51.461652524 -0400
+@@ -27,6 +27,7 @@
+ DESTDIR=
+ LIBDIR_NAME=lib
+ SHAREDLIB_DIR=$(PREFIX)/lib
++INCLUDES_DIR=$(PREFIX)/include
+ PROJECT_NAME=openh264
+ MODULE_NAME=gmpopenh264
+ GMP_API_BRANCH=Firefox39
+@@ -282,14 +283,14 @@
+ endif
+
+ $(PROJECT_NAME).pc: $(PROJECT_NAME).pc.in
+- @sed -e 's;@prefix@;$(PREFIX);' -e 's;@VERSION@;$(FULL_VERSION);' -e 's;@LIBS@;;' -e 's;@LIBS_PRIVATE@;$(STATIC_LDFLAGS);' < $< > $@
++ @sed -e 's;@prefix@;$(PREFIX);' -e 's;@sharedlibdir@;$(SHAREDLIB_DIR);' -e 's;@includesdir@;$(INCLUDES_DIR);' -e 's;@VERSION@;$(FULL_VERSION);' -e 's;@LIBS@;;' -e 's;@LIBS_PRIVATE@;$(STATIC_LDFLAGS);' < $< > $@
+
+ $(PROJECT_NAME)-static.pc: $(PROJECT_NAME).pc.in
+- @sed -e 's;@prefix@;$(PREFIX);' -e 's;@VERSION@;$(FULL_VERSION);' -e 's;@LIBS@;$(STATIC_LDFLAGS);' -e 's;@LIBS_PRIVATE@;;' < $< > $@
++ @sed -e 's;@prefix@;$(PREFIX);' -e 's;@sharedlibdir@;$(SHAREDLIB_DIR);' -e 's;@includesdir@;$(INCLUDES_DIR);' -e 's;@VERSION@;$(FULL_VERSION);' -e 's;@LIBS@;$(STATIC_LDFLAGS);' -e 's;@LIBS_PRIVATE@;;' < $< > $@
+
+ install-headers:
+- mkdir -p $(DESTDIR)$(PREFIX)/include/wels
+- install -m 644 $(SRC_PATH)/codec/api/svc/codec*.h $(DESTDIR)$(PREFIX)/include/wels
++ mkdir -p $(DESTDIR)$(INCLUDES_DIR)/wels
++ install -m 644 $(SRC_PATH)/codec/api/svc/codec*.h $(DESTDIR)$(INCLUDES_DIR)/wels
+
+ install-static-lib: $(LIBPREFIX)$(PROJECT_NAME).$(LIBSUFFIX) install-headers
+ mkdir -p $(DESTDIR)$(PREFIX)/$(LIBDIR_NAME)