summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/nas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/nas')
-rw-r--r--media-libs/nas/Manifest1
-rw-r--r--media-libs/nas/files/nas-1.9.2-asneeded.patch13
-rw-r--r--media-libs/nas/files/nas-1.9.4-remove-abs-fabs.patch36
-rw-r--r--media-libs/nas/files/nas.conf.d11
-rw-r--r--media-libs/nas/files/nas.init.d19
-rw-r--r--media-libs/nas/metadata.xml8
-rw-r--r--media-libs/nas/nas-1.9.4-r1.ebuild100
-rw-r--r--media-libs/nas/nas-1.9.4.ebuild99
8 files changed, 287 insertions, 0 deletions
diff --git a/media-libs/nas/Manifest b/media-libs/nas/Manifest
new file mode 100644
index 000000000000..19f46aaabc92
--- /dev/null
+++ b/media-libs/nas/Manifest
@@ -0,0 +1 @@
+DIST nas-1.9.4.src.tar.gz 1464598 SHA256 cf36ea63751ce86cfd3b76c1659ce0d6a361a2e7cb34069854e156532703b39d SHA512 3f8bd60f8ce0f25a2605af17caaadfe4f21223ba4cd3fa02078d1427b17cdf33ebda887e5dc30cd68eb7f64bfad80aafc9071ff0a26f0d3a4a93caacac03b5bb WHIRLPOOL 6c8e13d18bb9824dafc722ae6bb29d8adbfb778c9feddef56b41da77faceb730a5dc265fc7b613ae491fab0e6dbc4ede47d2abb98b313d3408783aee4e9a5db2
diff --git a/media-libs/nas/files/nas-1.9.2-asneeded.patch b/media-libs/nas/files/nas-1.9.2-asneeded.patch
new file mode 100644
index 000000000000..2ac89487a2c8
--- /dev/null
+++ b/media-libs/nas/files/nas-1.9.2-asneeded.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=247761
+
+--- config/NetAudio.tmpl
++++ config/NetAudio.tmpl
+@@ -162,7 +162,7 @@
+
+ AUDIODEPLIBS = $(DEPAULIB) $(DEPXTOOLLIB) $(DEPXLIB)
+ #ifndef WIN32
+- AUDIOLIBS = $(AULIB) $(XTOOLLIB) $(XLIB) -lm
++ AUDIOLIBS = $(AULIB) $(XTOOLLIB) $(XAUTHLIB) $(XLIB) -lm
+ #else /* WIN32 */
+ AUDIOLIBS = $(AULIB)
+ #endif /* WIN32 */
diff --git a/media-libs/nas/files/nas-1.9.4-remove-abs-fabs.patch b/media-libs/nas/files/nas-1.9.4-remove-abs-fabs.patch
new file mode 100644
index 000000000000..46ef6bb4610e
--- /dev/null
+++ b/media-libs/nas/files/nas-1.9.4-remove-abs-fabs.patch
@@ -0,0 +1,36 @@
+From 212309075d26668f6e25f30754e646952843cf61 Mon Sep 17 00:00:00 2001
+From: "Anthony G. Basile" <blueness@gentoo.org>
+Date: Tue, 28 Apr 2015 18:56:46 -0600
+Subject: [PATCH]
+
+On a uClibc system, the macro definitions of abs() and fabs()
+ cause the build to fail. Since these are specified by POSIX, it is safe to
+ just drop their definition. This has been tested on uClibc, glibc and musl.
+
+See: https://bugs.gentoo.org/show_bug.cgi?id=510766
+
+Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
+---
+ server/include/misc.h | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/server/include/misc.h b/server/include/misc.h
+index 2267ae0..fb904c8 100644
+--- a/server/include/misc.h
++++ b/server/include/misc.h
+@@ -71,12 +71,6 @@ typedef int Bool;
+
+ #define min(a, b) (((a) < (b)) ? (a) : (b))
+ #define max(a, b) (((a) > (b)) ? (a) : (b))
+-#ifndef abs
+-#define abs(a) ((a) > 0 ? (a) : -(a))
+-#endif
+-#ifndef fabs
+-#define fabs(a) ((a) > 0.0 ? (a) : -(a)) /* floating absolute value */
+-#endif
+ #define sign(x) ((x) < 0 ? -1 : ((x) > 0 ? 1 : 0))
+ /* this assumes b > 0 */
+ #define modulus(a, b, d) if (((d) = (a) % (b)) < 0) (d) += (b)
+--
+2.0.5
+
diff --git a/media-libs/nas/files/nas.conf.d b/media-libs/nas/files/nas.conf.d
new file mode 100644
index 000000000000..b8c32dbdba2b
--- /dev/null
+++ b/media-libs/nas/files/nas.conf.d
@@ -0,0 +1,11 @@
+# Config file for /etc/init.d/nas
+
+# For information on options, see "/usr/bin/nasd -h".
+
+NAS_OPTIONS=""
+
+# Allow only clients on local network to connect:
+#NAS_OPTIONS="-local"
+
+# Allow any client to connect:
+#NAS_OPTIONS="-aa"
diff --git a/media-libs/nas/files/nas.init.d b/media-libs/nas/files/nas.init.d
new file mode 100644
index 000000000000..6cfab54a4b1b
--- /dev/null
+++ b/media-libs/nas/files/nas.init.d
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+ after alsasound esd
+}
+
+start() {
+ ebegin "Starting nas"
+ start-stop-daemon --start --quiet --exec /usr/bin/nasd --background \
+ --pidfile /var/run/nasd.pid --make-pidfile -- $NAS_OPTIONS
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping nas"
+ start-stop-daemon --stop --quiet --pidfile /var/run/nasd.pid
+ eend $?
+}
diff --git a/media-libs/nas/metadata.xml b/media-libs/nas/metadata.xml
new file mode 100644
index 000000000000..c86db974637e
--- /dev/null
+++ b/media-libs/nas/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">nas</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/nas/nas-1.9.4-r1.ebuild b/media-libs/nas/nas-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..69107ee54529
--- /dev/null
+++ b/media-libs/nas/nas-1.9.4-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="Network Audio System"
+HOMEPAGE="http://radscan.com/nas.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
+
+LICENSE="HPND MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc static-libs"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-text/rman
+ sys-devel/bison
+ sys-devel/flex
+ x11-misc/gccmakedep
+ x11-misc/imake
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+
+DOCS=( BUILDNOTES FAQ HISTORY README RELEASE TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.9.2-asneeded.patch
+ epatch "${FILESDIR}"/${PN}-1.9.4-remove-abs-fabs.patch
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ xmkmf -a || die
+}
+
+multilib_src_compile() {
+ # EXTRA_LDOPTIONS, SHLIBGLOBALSFLAGS #336564#c2
+ local emakeopts=(
+ AR="$(tc-getAR) clq"
+ AS="$(tc-getAS)"
+ CC="$(tc-getCC)"
+ CDEBUGFLAGS="${CFLAGS}"
+ CXX="$(tc-getCXX)"
+ CXXDEBUFLAGS="${CXXFLAGS}"
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+ LD="$(tc-getLD)"
+ MAKE="${MAKE:-gmake}"
+ RANLIB="$(tc-getRANLIB)"
+ SHLIBGLOBALSFLAGS="${LDFLAGS}"
+ WORLDOPTS=
+ )
+
+ if multilib_is_native_abi ; then
+ # dumb fix for parallel make issue wrt #446598, Imake sux
+ emake "${emakeopts[@]}" -C server/dia all
+ emake "${emakeopts[@]}" -C server/dda/voxware all
+ emake "${emakeopts[@]}" -C server/os all
+ else
+ sed -i \
+ -e 's/SUBDIRS =.*/SUBDIRS = include lib config/' \
+ Makefile || die
+ fi
+
+ emake "${emakeopts[@]}" World
+}
+
+multilib_src_install() {
+ # ranlib is used at install phase too wrt #446600
+ emake RANLIB="$(tc-getRANLIB)" \
+ DESTDIR="${D}" USRLIBDIR=/usr/$(get_libdir) \
+ install install.man
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use doc; then
+ docinto doc
+ dodoc doc/{actions,protocol.txt,README}
+ docinto pdf
+ dodoc doc/pdf/*.pdf
+ fi
+
+ mv -vf "${D}"/etc/nas/nasd.conf{.eg,} || die
+
+ newconfd "${FILESDIR}"/nas.conf.d nas
+ newinitd "${FILESDIR}"/nas.init.d nas
+
+ use static-libs || rm -f "${D}"/usr/lib*/libaudio.a
+}
diff --git a/media-libs/nas/nas-1.9.4.ebuild b/media-libs/nas/nas-1.9.4.ebuild
new file mode 100644
index 000000000000..de1b31ce1d7d
--- /dev/null
+++ b/media-libs/nas/nas-1.9.4.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="Network Audio System"
+HOMEPAGE="http://radscan.com/nas.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
+
+LICENSE="HPND MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="doc static-libs"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-text/rman
+ sys-devel/bison
+ sys-devel/flex
+ x11-misc/gccmakedep
+ x11-misc/imake
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+
+DOCS=( BUILDNOTES FAQ HISTORY README RELEASE TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.9.2-asneeded.patch
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ xmkmf -a || die
+}
+
+multilib_src_compile() {
+ # EXTRA_LDOPTIONS, SHLIBGLOBALSFLAGS #336564#c2
+ local emakeopts=(
+ AR="$(tc-getAR) clq"
+ AS="$(tc-getAS)"
+ CC="$(tc-getCC)"
+ CDEBUGFLAGS="${CFLAGS}"
+ CXX="$(tc-getCXX)"
+ CXXDEBUFLAGS="${CXXFLAGS}"
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+ LD="$(tc-getLD)"
+ MAKE="${MAKE:-gmake}"
+ RANLIB="$(tc-getRANLIB)"
+ SHLIBGLOBALSFLAGS="${LDFLAGS}"
+ WORLDOPTS=
+ )
+
+ if multilib_is_native_abi ; then
+ # dumb fix for parallel make issue wrt #446598, Imake sux
+ emake "${emakeopts[@]}" -C server/dia all
+ emake "${emakeopts[@]}" -C server/dda/voxware all
+ emake "${emakeopts[@]}" -C server/os all
+ else
+ sed -i \
+ -e 's/SUBDIRS =.*/SUBDIRS = include lib config/' \
+ Makefile || die
+ fi
+
+ emake "${emakeopts[@]}" World
+}
+
+multilib_src_install() {
+ # ranlib is used at install phase too wrt #446600
+ emake RANLIB="$(tc-getRANLIB)" \
+ DESTDIR="${D}" USRLIBDIR=/usr/$(get_libdir) \
+ install install.man
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use doc; then
+ docinto doc
+ dodoc doc/{actions,protocol.txt,README}
+ docinto pdf
+ dodoc doc/pdf/*.pdf
+ fi
+
+ mv -vf "${D}"/etc/nas/nasd.conf{.eg,} || die
+
+ newconfd "${FILESDIR}"/nas.conf.d nas
+ newinitd "${FILESDIR}"/nas.init.d nas
+
+ use static-libs || rm -f "${D}"/usr/lib*/libaudio.a
+}