summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-04 00:26:58 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-04 00:38:14 -0500
commit3b414dbc1a8f3b4025c9b629a3a0fa3d8e756ec1 (patch)
tree658f33be7fec25201a4432ad8b81b505696c86b1 /media-libs/nas
parentapp-emacs/org-mode: update live (diff)
downloadgentoo-3b414dbc1a8f3b4025c9b629a3a0fa3d8e756ec1.tar.gz
gentoo-3b414dbc1a8f3b4025c9b629a3a0fa3d8e756ec1.tar.bz2
gentoo-3b414dbc1a8f3b4025c9b629a3a0fa3d8e756ec1.zip
media-libs/nas: workaround imake argument splitting
IMAKECPP normally doesn't support arguments but was given the same basic support as IMAKEINCLUDE which doesn't handle multiple spaces or tab, and an empty get_abi_CFLAGS would result in two spaces without an argument. So use an array and word splitting to normalize. Closes: https://bugs.gentoo.org/884203 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-libs/nas')
-rw-r--r--media-libs/nas/nas-1.9.5.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/media-libs/nas/nas-1.9.5.ebuild b/media-libs/nas/nas-1.9.5.ebuild
index d7e197596b34..361d40334d52 100644
--- a/media-libs/nas/nas-1.9.5.ebuild
+++ b/media-libs/nas/nas-1.9.5.ebuild
@@ -53,8 +53,10 @@ multilib_src_configure() {
pushd config || die
econf
popd || die
+
+ local cpp=($(get_abi_CHOST ${DEFAULT_ABI})-gcc $(get_abi_CFLAGS) -E) #884203
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(get_abi_CHOST ${DEFAULT_ABI})-gcc $(get_abi_CFLAGS) -E}" \
+ IMAKECPP="${IMAKECPP:-${cpp[*]}}" \
xmkmf -a || die
}