summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-08-29 16:21:13 -0400
committerMatt Turner <mattst88@gentoo.org>2023-08-29 16:22:11 -0400
commit75efa513eb6d609f9d849f0e59c125e377bdcd80 (patch)
treef1fa6536629ee485ff776fb842c90d4495b2183b /media-libs/mesa
parentapp-emacs/emacs-common: Stabilize 1.9 ppc, #913221 (diff)
downloadgentoo-75efa513eb6d609f9d849f0e59c125e377bdcd80.tar.gz
gentoo-75efa513eb6d609f9d849f0e59c125e377bdcd80.tar.bz2
gentoo-75efa513eb6d609f9d849f0e59c125e377bdcd80.zip
media-libs/mesa: Conditionalize ply check with 'use llvm'
Missed in 0486dbce0557 ("media-libs/mesa: Put raytracing deps behind USE=llvm"). Bug: https://bugs.gentoo.org/910435 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-23.1.6.ebuild2
-rw-r--r--media-libs/mesa/mesa-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-23.1.6.ebuild b/media-libs/mesa/mesa-23.1.6.ebuild
index 21f4b200e667..19073addfdf5 100644
--- a/media-libs/mesa/mesa-23.1.6.ebuild
+++ b/media-libs/mesa/mesa-23.1.6.ebuild
@@ -256,7 +256,7 @@ pkg_pretend() {
python_check_deps() {
python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]" || return 1
- if use vulkan && use video_cards_intel && use amd64; then
+ if use llvm && use vulkan && use video_cards_intel && use amd64; then
python_has_version -b "dev-python/ply[${PYTHON_USEDEP}]" || return 1
fi
}
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 38259ac52a7b..11458c0cb174 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -252,7 +252,7 @@ pkg_pretend() {
python_check_deps() {
python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]" || return 1
- if use vulkan && use video_cards_intel && use amd64; then
+ if use llvm && use vulkan && use video_cards_intel && use amd64; then
python_has_version -b "dev-python/ply[${PYTHON_USEDEP}]" || return 1
fi
}