summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/lvtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/lvtk')
-rw-r--r--media-libs/lvtk/Manifest1
-rw-r--r--media-libs/lvtk/lvtk-1.2.0.ebuild51
-rw-r--r--media-libs/lvtk/metadata.xml12
3 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/lvtk/Manifest b/media-libs/lvtk/Manifest
new file mode 100644
index 000000000000..4dbf21936fd5
--- /dev/null
+++ b/media-libs/lvtk/Manifest
@@ -0,0 +1 @@
+DIST lvtk-1.2.0.tar.gz 201146 SHA256 4dda4c26a16fc3f216ff77f5bb308f05667640e54fc80f0ae4984e869990cb0e SHA512 f193ec28103cb2f6353ff0f96f8790041baf1ae99472c5d04017c23b42d0179b1f5e1de6722e17080410311d0e7e1de4ca0ae9ab76fb3bf8a02d9dc1451d8db7 WHIRLPOOL c7a70d033a2a02b02f890cc68789b376e7e4e53231290dbaa5bb85abf0d3b53cb64afe352bab6d71ddcd77a5f4d002073564ebc398d6f35d7cc75bc1b49728e2
diff --git a/media-libs/lvtk/lvtk-1.2.0.ebuild b/media-libs/lvtk/lvtk-1.2.0.ebuild
new file mode 100644
index 000000000000..b5a3bb13143f
--- /dev/null
+++ b/media-libs/lvtk/lvtk-1.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-single-r1 waf-utils
+
+DESCRIPTION="A set of C++ wrappers around the LV2 C API"
+HOMEPAGE="http://lvtoolkit.org/"
+SRC_URI="https://github.com/lvtk/lvtk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples +gtk2 +tools"
+
+RDEPEND="media-libs/lv2
+ >=dev-libs/boost-1.40.0
+ gtk2? ( dev-cpp/gtkmm:2.4 )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ local mywafconfargs=(
+ "--docdir=${EPREFIX}/usr/share/doc/${PF}"
+ "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2"
+ )
+ use debug && mywafconfargs+=( "--debug" )
+ use doc && mywafconfargs+=( "--docs" )
+ use examples || mywafconfargs+=( "--disable-examples" )
+ use tools || mywafconfargs+=( "--disable-tools" )
+ use gtk2 || mywafconfargs+=( "--disable-ui" )
+ waf-utils_src_configure ${mywafconfargs[@]}
+}
+
+src_install() {
+ waf-utils_src_install
+
+ # It does not respect docdir properly, reported upstream
+ if use doc; then
+ mv "${ED}/usr/share/doc/${PF}/lvtk-1.0/html" "${ED}/usr/share/doc/${PF}/html"
+ rmdir "${ED}/usr/share/doc/${PF}/lvtk-1.0"
+ fi
+}
diff --git a/media-libs/lvtk/metadata.xml b/media-libs/lvtk/metadata.xml
new file mode 100644
index 000000000000..5a7d94e97b70
--- /dev/null
+++ b/media-libs/lvtk/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <use>
+ <flag name="gtk2">Enable <pkg>x11-libs/gtk+:2</pkg> based GUI support</flag>
+ <flag name="tools">Compile and install ttl2c tool</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">lvtk/lvtk</remote-id>
+ </upstream>
+</pkgmetadata>