summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-11-13 11:43:08 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-11-13 13:04:25 -0500
commita79486b955470a924512dacec5d7341334b6f9a1 (patch)
tree879aab803bd6e9226f4cc9fd33a6afa4435450c1 /media-libs/librosprite
parentmedia-libs/libnspsl: drop netsurf eclass (diff)
downloadgentoo-a79486b955470a924512dacec5d7341334b6f9a1.tar.gz
gentoo-a79486b955470a924512dacec5d7341334b6f9a1.tar.bz2
gentoo-a79486b955470a924512dacec5d7341334b6f9a1.zip
media-libs/librosprite: drop netsurf eclass
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-libs/librosprite')
-rw-r--r--media-libs/librosprite/Manifest1
-rw-r--r--media-libs/librosprite/librosprite-0.1.3-r1.ebuild33
-rw-r--r--media-libs/librosprite/librosprite-0.1.3.ebuild23
3 files changed, 33 insertions, 24 deletions
diff --git a/media-libs/librosprite/Manifest b/media-libs/librosprite/Manifest
index ab80a230877a..69decde29f4a 100644
--- a/media-libs/librosprite/Manifest
+++ b/media-libs/librosprite/Manifest
@@ -1,2 +1 @@
DIST librosprite-0.1.3-src.tar.gz 32816 BLAKE2B 553f5046eac8b7de5940e812103a545ee1d599bcc30d4fd6bb14449e0718364132e76e3992b224d0d2dd3c7582100fe6d9e4d433f245a89b23e3f15542329e0e SHA512 ab039ab12df7f527a86a76247bc5cb70ebe550591f81a1b987abef73fb3c6bd25c9a36afe17bd6717f4f33b1a133d847bb5acad53057aa3c406efe4ebcdc601b
-DIST netsurf-buildsystem-1.7.tar.gz 38597 BLAKE2B d0981ef282ac0d93d81a1a6a6bee1fc2a0151c962be6ce2900a67843ba8ebc67e00508cded2a7375f6bbe0d45572690f127872936a282de80eb08655ac571603 SHA512 f6a46ac25f41e695ec13d7b2b564250c4cc44a40a688904eb17aa4b547c2df0102cc0effb7a23a2ffa6b9178ae5cf452b63980caf26e06e479168c85803f1e58
diff --git a/media-libs/librosprite/librosprite-0.1.3-r1.ebuild b/media-libs/librosprite/librosprite-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..b1caf0f8beff
--- /dev/null
+++ b/media-libs/librosprite/librosprite-0.1.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="framebuffer abstraction library, written in C"
+HOMEPAGE="http://www.netsurf-browser.org/projects/librosprite/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~m68k-mint"
+IUSE=""
+
+DEPEND="dev-util/netsurf-buildsystem"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.1.2-Werror.patch )
+
+_emake() {
+ source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install
+}
diff --git a/media-libs/librosprite/librosprite-0.1.3.ebuild b/media-libs/librosprite/librosprite-0.1.3.ebuild
deleted file mode 100644
index 1f18c60fddd5..000000000000
--- a/media-libs/librosprite/librosprite-0.1.3.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-NETSURF_BUILDSYSTEM=buildsystem-1.7
-inherit netsurf
-
-DESCRIPTION="framebuffer abstraction library, written in C"
-HOMEPAGE="http://www.netsurf-browser.org/projects/librosprite/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~m68k-mint"
-IUSE=""
-
-PATCHES=( "${FILESDIR}"/${PN}-0.1.2-Werror.patch )
-
-src_prepare() {
- # working around broken netsurf eclass
- default
- multilib_copy_sources
-}