summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-06 11:15:19 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-06 11:15:55 -0500
commitbd3349816acc223b3b02527b5d703a36c29ce716 (patch)
tree37693e29d0ffed80f77eec067bd55e29187f83a7 /media-libs/libprojectm
parentwww-servers/nginx: bump to v1.14.1 stable (diff)
downloadgentoo-bd3349816acc223b3b02527b5d703a36c29ce716.tar.gz
gentoo-bd3349816acc223b3b02527b5d703a36c29ce716.tar.bz2
gentoo-bd3349816acc223b3b02527b5d703a36c29ce716.zip
media-libs/libprojectm: Add dependency on media-libs/glm
Closes: https://bugs.gentoo.org/670428 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-libs/libprojectm')
-rw-r--r--media-libs/libprojectm/libprojectm-3.1.0-r1.ebuild55
-rw-r--r--media-libs/libprojectm/libprojectm-9999.ebuild51
2 files changed, 106 insertions, 0 deletions
diff --git a/media-libs/libprojectm/libprojectm-3.1.0-r1.ebuild b/media-libs/libprojectm/libprojectm-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..bd704657cdc9
--- /dev/null
+++ b/media-libs/libprojectm/libprojectm-3.1.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A graphical music visualization plugin similar to milkdrop"
+HOMEPAGE="https://github.com/projectM-visualizer/projectm"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projectM-visualizer/projectm.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/projectM-visualizer/projectm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+ S=${WORKDIR}/projectm-${PV}/
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="gles2 qt5 sdl"
+
+RDEPEND="gles2? ( media-libs/mesa[gles2] )
+ media-libs/glm
+ media-libs/mesa
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtopengl:5
+ media-sound/pulseaudio
+ )
+ sdl? ( >=media-libs/libsdl2-2.0.5 )
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-datadir.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gles2 gles ) \
+ $(use_enable qt5 qt ) \
+ $(use_enable sdl ) \
+ --enable-emscripten=no
+}
diff --git a/media-libs/libprojectm/libprojectm-9999.ebuild b/media-libs/libprojectm/libprojectm-9999.ebuild
new file mode 100644
index 000000000000..26589f453934
--- /dev/null
+++ b/media-libs/libprojectm/libprojectm-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A graphical music visualization plugin similar to milkdrop"
+HOMEPAGE="https://github.com/projectM-visualizer/projectm"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projectM-visualizer/projectm.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/projectM-visualizer/projectm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ S=${WORKDIR}/projectm-${PV}/
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="gles2 qt5 sdl"
+
+RDEPEND="gles2? ( media-libs/mesa[gles2] )
+ media-libs/glm
+ media-libs/mesa
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtopengl:5
+ media-sound/pulseaudio
+ )
+ sdl? ( >=media-libs/libsdl2-2.0.5 )
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gles2 gles ) \
+ $(use_enable qt5 qt ) \
+ $(use_enable sdl ) \
+ --enable-emscripten=no
+}