summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-13 19:30:57 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-13 19:35:06 +0200
commit4585f3ce9b02b841a713a6712f81a3d5111005c5 (patch)
tree90a0fbfab14d00b81feaa865aa83ddf797e4ba4f /media-libs/libopenshot
parentmedia-gfx/mypaint: Drop old (diff)
downloadgentoo-4585f3ce9b02b841a713a6712f81a3d5111005c5.tar.gz
gentoo-4585f3ce9b02b841a713a6712f81a3d5111005c5.tar.bz2
gentoo-4585f3ce9b02b841a713a6712f81a3d5111005c5.zip
media-libs/libopenshot: Version bump, fix imagemagick7 compat (#626014)
Closes: https://bugs.gentoo.org/626014 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-libs/libopenshot')
-rw-r--r--media-libs/libopenshot/Manifest1
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/media-libs/libopenshot/Manifest b/media-libs/libopenshot/Manifest
index 19d8b0b08ff1..be122d9c41a5 100644
--- a/media-libs/libopenshot/Manifest
+++ b/media-libs/libopenshot/Manifest
@@ -1,3 +1,4 @@
DIST libopenshot-0.1.3.tar.gz 11019740 BLAKE2B a706889f709024300ef79518406da861111a8445b5ce23364b8492a72e74e7944c88ba9b4a29da356ca21500253d19e8c32abe7b5aaa0ac35bebec85e52ba970 SHA512 d59817505812868db408a88dc1d30b5b1833910f45dd0df03937110b7d4cbd85a270773008e75a1501f4b3b89a09ea798ed9b580755adf3ae79ac24d403f6982
DIST libopenshot-0.1.7.tar.gz 11022594 BLAKE2B f3e0836ebb6dd89ce42085dc9d18dd3bce9ab3011550958bec41eead2c62b454459d219d2efeece1a43eb0536cb99866eaf9b478205d717da4c173e954772a46 SHA512 4c8871ff30c03a14766e35a64052695768311afd81ecc55598720ad146f53c122ef3b1293467670f7dd48da77bf6cb4f4f14a18c298a649b8827f901ed653709
DIST libopenshot-0.1.8.tar.gz 11019495 BLAKE2B a86994a09328e24705fe06ec3c47cbedb89815e6ec1440237dc58babfc066655f1c7dacc19257b02b645a9415c63cd4e0c1191fa452b7632cf531d98a1b073c3 SHA512 02630d7ce9fd378ad648d034622d4f971728a2074691d7facc8a36dcd52b87c1372dd5a9588c0ba852589105bdbf78941083fd6b1eb1bcc0a33d4ca49634162c
+DIST libopenshot-0.2.2.tar.gz 11037768 BLAKE2B c307e41bf17d40ae421a541bbdf4cd53c6ef4d97041a476c6910bd156c10815aa5a5811813b24fdc472401516f29cf8cb68fbda17a0b434767c3f3aa63d6f222 SHA512 b89189e57e82da68a063417bba9c94704c04b0546c0aed227daa23a794eee56341a05988d8e28dbd339edfcdeeaed48103b347060eccf94f32fe1a4bf23d6553
diff --git a/media-libs/libopenshot/libopenshot-0.2.2.ebuild b/media-libs/libopenshot/libopenshot-0.2.2.ebuild
new file mode 100644
index 000000000000..4b0aeae13e16
--- /dev/null
+++ b/media-libs/libopenshot/libopenshot-0.2.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils python-single-r1 toolchain-funcs versionator
+
+DESCRIPTION="Video editing library used by OpenShot"
+HOMEPAGE="http://www.openshotvideo.com/"
+SRC_URI="https://github.com/OpenShot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+imagemagick libav +python test"
+# https://github.com/OpenShot/libopenshot/issues/43
+RESTRICT="test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ net-libs/cppzmq
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[widgets]
+ >=media-libs/libopenshot-audio-0.1.4
+ imagemagick? ( >=media-gfx/imagemagick-7:0=[cxx] )
+ libav? ( media-video/libav:=[encode,x264,xvid,vpx,mp3,theora] )
+ !libav? ( media-video/ffmpeg:0=[encode,x264,xvid,vpx,mp3,theora] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+ python? ( dev-lang/swig )
+ test? ( dev-libs/unittest++ )
+"
+
+# From Mageia
+# https://github.com/OpenShot/libopenshot/issues/60
+PATCHES=( ${FILESDIR}/${PN}-0.2.2-imagemagick7.patch )
+
+check_compiler() {
+ if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
+ eerror "${P} requires a compiler with OpenMP support. Your current"
+ eerror "compiler does not support it. If you use gcc, you can"
+ eerror "re-emerge it with the 'openmp' use flag enabled."
+ die "The current compiler does not support OpenMP"
+ fi
+}
+
+pkg_pretend() {
+ check_compiler
+}
+
+pkg_setup() {
+ check_compiler
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # https://github.com/OpenShot/libopenshot/issues/17
+ use test || cmake_comment_add_subdirectory tests
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_RUBY=OFF # TODO: add ruby support
+ -DENABLE_PYTHON=$(usex python)
+ $(cmake-utils_use_find_package imagemagick ImageMagick)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_make test
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize
+}