summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-10 11:50:36 +0100
committerIan Delaney <idella4@gentoo.org>2016-03-15 21:32:05 +0800
commit6c38b433d6d20b7bc104b617b4d54ada6f457a53 (patch)
tree82cd0cb96a111b1322809bd7ac208750fa5cc10a /media-libs/libopenshot-audio
parentapp-text/ronn: amd64 stable wrt bug #576632 (diff)
downloadgentoo-6c38b433d6d20b7bc104b617b4d54ada6f457a53.tar.gz
gentoo-6c38b433d6d20b7bc104b617b4d54ada6f457a53.tar.bz2
gentoo-6c38b433d6d20b7bc104b617b4d54ada6f457a53.zip
media-libs/libopenshot-audio: new ebuild, version 0.0.6
Needed for media-video/openshot-2.0.6 Package-Manager: portage-2.2.27 Closes: https://github.com/gentoo/gentoo/pull/1023
Diffstat (limited to 'media-libs/libopenshot-audio')
-rw-r--r--media-libs/libopenshot-audio/Manifest1
-rw-r--r--media-libs/libopenshot-audio/libopenshot-audio-0.0.6.ebuild37
-rw-r--r--media-libs/libopenshot-audio/metadata.xml19
3 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/libopenshot-audio/Manifest b/media-libs/libopenshot-audio/Manifest
new file mode 100644
index 000000000000..3f783fab9703
--- /dev/null
+++ b/media-libs/libopenshot-audio/Manifest
@@ -0,0 +1 @@
+DIST libopenshot-audio-0.0.6.tar.gz 2963454 SHA256 29707bf7603fc08b2a152abff2599405f3499a2d674919b1a1749638cd91f42e SHA512 20ea1805134f899d845469dacca6bb86eaa6e6cb55cea22acca0ff5e4261782ecdedaa44454e2eb449183a985130861d305402f5cce37da4624650a786167993 WHIRLPOOL 1d9638ebc268190e2ef9c4ad93e1b4c86734940488660e65beef4f4362b2e9a1b5602f0717918ded89b8d588251d3fedff91cfd41c9425fb6d63c408b332478c
diff --git a/media-libs/libopenshot-audio/libopenshot-audio-0.0.6.ebuild b/media-libs/libopenshot-audio/libopenshot-audio-0.0.6.ebuild
new file mode 100644
index 000000000000..d2e6928e40f2
--- /dev/null
+++ b/media-libs/libopenshot-audio/libopenshot-audio-0.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Audio library used by OpenShot"
+HOMEPAGE="http://www.openshot.org/ https://launchpad.net/libopenshot"
+SRC_URI="https://launchpad.net/libopenshot/0.1/0.1.0/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/alsa-lib
+ media-libs/freetype
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ ${RDEPEND}
+"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ # fix under-linking
+ # https://github.com/OpenShot/libopenshot-audio/issues/3
+ sed -i 's/^\(target_link_libraries(.*\))$/\1 dl pthread)/' \
+ src/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
diff --git a/media-libs/libopenshot-audio/metadata.xml b/media-libs/libopenshot-audio/metadata.xml
new file mode 100644
index 000000000000..c77645c765eb
--- /dev/null
+++ b/media-libs/libopenshot-audio/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">libopenshot</remote-id>
+ <remote-id type="github">OpenShot/libopenshot-audio</remote-id>
+ <bugs-to>https://github.com/OpenShot/libopenshot-audio/issues</bugs-to>
+ <bugs-to>https://bugs.launchpad.net/libopenshot/+bugs</bugs-to>
+ </upstream>
+</pkgmetadata>