summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-22 00:48:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-22 01:14:54 +0100
commitdfb47abac5677162a891c20873f4f523b56994e5 (patch)
tree18fe784e3d7780bce54075d212398baeaa0198c2 /media-libs/libmypaint
parentapp-backup/dar: Removed old. (diff)
downloadgentoo-dfb47abac5677162a891c20873f4f523b56994e5.tar.gz
gentoo-dfb47abac5677162a891c20873f4f523b56994e5.tar.bz2
gentoo-dfb47abac5677162a891c20873f4f523b56994e5.zip
media-libs/libmypaint: Bump to version 1.3.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/libmypaint')
-rw-r--r--media-libs/libmypaint/Manifest1
-rw-r--r--media-libs/libmypaint/libmypaint-1.3.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/libmypaint/Manifest b/media-libs/libmypaint/Manifest
index bf753e8503b2..1f51ab5c6895 100644
--- a/media-libs/libmypaint/Manifest
+++ b/media-libs/libmypaint/Manifest
@@ -1 +1,2 @@
DIST libmypaint-1.3.0-beta.1.tar.xz 421424 SHA256 d39138b21b9057376138e64f09f4c4741a14a7baed71d6f0ba9bc2504d69f9ee SHA512 ae98ec8947d521749d82bc1e683efcace2da7e3c8b8453e79e5191d65225f0963394344628d646947f79b141503d268277d26ce2eeaf482bbe24f1bfb1d103fa WHIRLPOOL af50526090b0613d3eca89dd8a6773f93889d2b966263e1497c8008bf2ef73c491559ddb5c14a3bfa9c4d407755780b4a9d54a2f6a572eedf2a9415d6ce4ef45
+DIST libmypaint-1.3.0.tar.xz 438160 SHA256 6a07d9d57fea60f68d218a953ce91b168975a003db24de6ac01ad69dcc94a671 SHA512 553eeb3439ffd0c013e33254a16334242583b8bab76d1a3e937f3ed1d7e05a832c6eb26acd7220dce20c6a7d997c32afe828202ce48e25a5fe57b67efd853fcf WHIRLPOOL ea0abb1e0a57d430d1b3aaa0701ef577dc529b6aa3ae3423dc924bcd59aaba06a98c1d2ddddb26279d545049ce74f9bb00f2f7e62533e8ac45ea3cf4dd109fec
diff --git a/media-libs/libmypaint/libmypaint-1.3.0.ebuild b/media-libs/libmypaint/libmypaint-1.3.0.ebuild
new file mode 100644
index 000000000000..e1c204cf740a
--- /dev/null
+++ b/media-libs/libmypaint/libmypaint-1.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-any-r1 xdg-utils toolchain-funcs
+
+MY_PV=${PV/_beta/-beta.}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Library for making brushstrokes"
+HOMEPAGE="https://github.com/mypaint/libmypaint"
+SRC_URI="https://github.com/mypaint/libmypaint/releases/download/v${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0/0" # first soname component for subslot
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="gegl introspection nls openmp"
+
+CDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-c
+ gegl? (
+ media-libs/babl
+ media-libs/gegl:0.3[introspection?]
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.32 )
+ openmp? ( sys-devel/gcc:*[openmp] )
+ nls? ( sys-devel/gettext )
+ "
+DEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ nls? ( dev-util/intltool )
+ "
+RDEPEND="${CDEPEND}
+ !<media-gfx/mypaint-1.2.1
+ "
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ xdg_environment_reset
+ eapply_user
+}
+
+src_configure() {
+ tc-ld-disable-gold # bug 589266
+ econf \
+ --disable-debug \
+ --disable-docs \
+ $(use_enable gegl) \
+ --disable-gperftools \
+ $(use_enable nls i18n) \
+ $(use_enable introspection) \
+ $(use_enable openmp) \
+ --disable-profiling
+}