summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libmetalink
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libmetalink')
-rw-r--r--media-libs/libmetalink/Manifest2
-rw-r--r--media-libs/libmetalink/libmetalink-0.1.0-r1.ebuild30
-rw-r--r--media-libs/libmetalink/libmetalink-0.1.1-r1.ebuild31
-rw-r--r--media-libs/libmetalink/libmetalink-0.1.1.ebuild28
-rw-r--r--media-libs/libmetalink/metadata.xml11
5 files changed, 102 insertions, 0 deletions
diff --git a/media-libs/libmetalink/Manifest b/media-libs/libmetalink/Manifest
new file mode 100644
index 000000000000..0f50d8c972aa
--- /dev/null
+++ b/media-libs/libmetalink/Manifest
@@ -0,0 +1,2 @@
+DIST libmetalink-0.1.0.tar.bz2 324033 SHA256 501c980b0892e1c25bd20f0c69a166672571caf56a732d73851ff3e6a2eb0cf6 SHA512 50d6dd0a7def447261d44a586a2971b646f69d82e67e7c181c01a876e9177f164f3e9d67268dd0064b6b4ba9555ce2932eb9753e2d291f5263f5622af6e06bda WHIRLPOOL 6070a0578a555b8c11b0e6da69f768da13832467cfe50a552775d03af9df0f400470ed9cdc043aac5e9a7fabec1b721bcfd14cfe3828440d5c59898ca62f5eb8
+DIST libmetalink-0.1.1.tar.bz2 324472 SHA256 fd6d45c84c10cbc7a6e1b0ebbd81198a01866fa88cd01ceb2b0c448f5e74bcfb SHA512 9e9a2bf17b3696b199844703377cf6615bab44fd61b89be9afef579c21b0ac462f156719f60df9b8e7f7a9edb259d9bf461f20cd11ad9960d8376bf20e04f62c WHIRLPOOL 8ac61f6c4e739d752c5a7547bc9894d9a4a1bf5085cc67eda30d0d8cf14ffb1790f122b9a452452f91319400c10a31dd9995ea422148adc6d666db2392606962
diff --git a/media-libs/libmetalink/libmetalink-0.1.0-r1.ebuild b/media-libs/libmetalink/libmetalink-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..b7db60f17a4e
--- /dev/null
+++ b/media-libs/libmetalink/libmetalink-0.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base
+
+DESCRIPTION="Library for handling Metalink files"
+HOMEPAGE="http://launchpad.net/libmetalink"
+SRC_URI="https://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 x86"
+IUSE="expat static-libs test xml"
+
+RDEPEND="expat? ( dev-libs/expat )
+ xml? ( >=dev-libs/libxml2-2.6.24 )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cunit )"
+
+REQUIRED_USE="^^ ( expat xml )"
+
+src_configure() {
+ econf \
+ $(use_with expat libexpat) \
+ $(use_with xml libxml2) \
+ $(use_enable static-libs static)
+}
diff --git a/media-libs/libmetalink/libmetalink-0.1.1-r1.ebuild b/media-libs/libmetalink/libmetalink-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..74497392f54a
--- /dev/null
+++ b/media-libs/libmetalink/libmetalink-0.1.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib-minimal
+
+DESCRIPTION="Library for handling Metalink files"
+HOMEPAGE="http://launchpad.net/libmetalink"
+SRC_URI="https://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 x86"
+IUSE="expat static-libs test xml"
+
+RDEPEND="expat? ( >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}] )
+ xml? ( >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1_p2[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="^^ ( expat xml )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_with expat libexpat) \
+ $(use_with xml libxml2) \
+ $(use_enable static-libs static)
+}
diff --git a/media-libs/libmetalink/libmetalink-0.1.1.ebuild b/media-libs/libmetalink/libmetalink-0.1.1.ebuild
new file mode 100644
index 000000000000..5e1f53bcc4b5
--- /dev/null
+++ b/media-libs/libmetalink/libmetalink-0.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Library for handling Metalink files"
+HOMEPAGE="http://launchpad.net/libmetalink"
+SRC_URI="https://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 x86"
+IUSE="expat static-libs test xml"
+
+RDEPEND="expat? ( dev-libs/expat )
+ xml? ( >=dev-libs/libxml2-2.6.24 )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cunit )"
+
+REQUIRED_USE="^^ ( expat xml )"
+
+src_configure() {
+ econf \
+ $(use_with expat libexpat) \
+ $(use_with xml libxml2) \
+ $(use_enable static-libs static)
+}
diff --git a/media-libs/libmetalink/metadata.xml b/media-libs/libmetalink/metadata.xml
new file mode 100644
index 000000000000..af537d205438
--- /dev/null
+++ b/media-libs/libmetalink/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">libmetalink</remote-id>
+ </upstream>
+</pkgmetadata>