summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libifp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libifp')
-rw-r--r--media-libs/libifp/Manifest1
-rw-r--r--media-libs/libifp/libifp-1.0.0.2.ebuild57
-rw-r--r--media-libs/libifp/metadata.xml8
3 files changed, 66 insertions, 0 deletions
diff --git a/media-libs/libifp/Manifest b/media-libs/libifp/Manifest
new file mode 100644
index 000000000000..1e8e1cc0fc1d
--- /dev/null
+++ b/media-libs/libifp/Manifest
@@ -0,0 +1 @@
+DIST libifp-1.0.0.2.tar.gz 358550 SHA256 3b8fa50b9425b660285484eb42bad3f736f0aecc6a790c5160da276558ebfcee
diff --git a/media-libs/libifp/libifp-1.0.0.2.ebuild b/media-libs/libifp/libifp-1.0.0.2.ebuild
new file mode 100644
index 000000000000..4d9a1c4d6ad4
--- /dev/null
+++ b/media-libs/libifp/libifp-1.0.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="A general-purpose library for iRiver's iFP portable audio players"
+HOMEPAGE="http://ifp-driver.sourceforge.net/libifp/"
+SRC_URI="mirror://sourceforge/ifp-driver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86"
+IUSE="doc examples static-libs"
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.3.7 )
+ sys-apps/sed"
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS=/s:-g -O2:${CFLAGS}:' \
+ -e '/CXXFLAGS=/s:-g -O2:${CXXFLAGS}:' \
+ configure || die
+}
+
+src_configure() {
+ use doc || export have_doxygen=no
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable examples) \
+ --with-libusb \
+ --without-kmodule
+}
+
+src_test() { :; } # hardware dependant wrt #318597
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+
+ # clean /usr/bin after installation
+ # by moving examples to examples dir
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins "${S}"/examples/simple.c "${S}"/examples/ifpline.c
+ mv "${D}"/usr/bin/{simple,ifpline} "${D}"/usr/share/${PN}/examples
+ else
+ rm -f "${D}"/usr/bin/{simple,ifpline}
+ fi
+
+ use doc && dodoc README ChangeLog TODO
+}
diff --git a/media-libs/libifp/metadata.xml b/media-libs/libifp/metadata.xml
new file mode 100644
index 000000000000..74257d7e3e82
--- /dev/null
+++ b/media-libs/libifp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">ifp-driver</remote-id>
+ </upstream>
+</pkgmetadata>