summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-10-12 23:08:16 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-10-12 23:18:50 +0200
commit54550720b42f8a4bb3adaf6727ce8a47c5ed7892 (patch)
tree8f373eeeb53a3716ac9748ba01defb4b8c57b7e1 /media-libs/libfpx/libfpx-1.3.1_p10.ebuild
parentnet-irc/konversation: Fix crash on extended joins (diff)
downloadgentoo-54550720b42f8a4bb3adaf6727ce8a47c5ed7892.tar.gz
gentoo-54550720b42f8a4bb3adaf6727ce8a47c5ed7892.tar.bz2
gentoo-54550720b42f8a4bb3adaf6727ce8a47c5ed7892.zip
media-libs/libfpx: Bump to v1.3.1_p10 (CVE-2017-{12920,12921,12925})
Bug: https://bugs.gentoo.org/628190 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'media-libs/libfpx/libfpx-1.3.1_p10.ebuild')
-rw-r--r--media-libs/libfpx/libfpx-1.3.1_p10.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/libfpx/libfpx-1.3.1_p10.ebuild b/media-libs/libfpx/libfpx-1.3.1_p10.ebuild
new file mode 100644
index 000000000000..1393c3382531
--- /dev/null
+++ b/media-libs/libfpx/libfpx-1.3.1_p10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A library for manipulating FlashPIX images"
+HOMEPAGE="http://www.i3a.org/"
+SRC_URI="mirror://imagemagick/delegates/${P/_p/-}.tar.bz2"
+
+LICENSE="Flashpix"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="static-libs"
+
+S=${WORKDIR}/${P/_p/-}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0.13-export-symbols.patch
+)
+
+src_prepare() {
+ default
+
+ # we're not windows, even though we don't define __unix by default
+ [[ ${CHOST} == *-darwin* ]] && append-flags -D__unix
+
+ elibtoolize
+}
+
+src_configure() {
+ append-ldflags -Wl,--no-undefined
+ econf \
+ $(use_enable static-libs static) \
+ LIBS="-lstdc++ -lm"
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog doc/*.txt
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/*.pdf
+}