summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 16:26:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 16:48:04 +0100
commit8b879fded0dc01423d42526dbab7e9f66eefedbc (patch)
tree5ab3e764fb83c0e30dd9a4e28109feef83c51d10 /media-libs/libaom/libaom-2.0.0.ebuild
parentmedia-libs/libavif: Drop 0.8.4-r1, 0.9.0-r3, 0.9.1-r1, 0.9.2-r1 (diff)
downloadgentoo-8b879fded0dc01423d42526dbab7e9f66eefedbc.tar.gz
gentoo-8b879fded0dc01423d42526dbab7e9f66eefedbc.tar.bz2
gentoo-8b879fded0dc01423d42526dbab7e9f66eefedbc.zip
media-libs/libaom: Cleanup vulnerable 2.0.0, 2.0.1 and 3.1.2
Bug: https://bugs.gentoo.org/828112 Bug: https://bugs.gentoo.org/793932 Bug: https://bugs.gentoo.org/798126 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libaom/libaom-2.0.0.ebuild')
-rw-r--r--media-libs/libaom/libaom-2.0.0.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/media-libs/libaom/libaom-2.0.0.ebuild b/media-libs/libaom/libaom-2.0.0.ebuild
deleted file mode 100644
index 1218908d6994..000000000000
--- a/media-libs/libaom/libaom-2.0.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
-else
- SRC_URI="https://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.gz"
- S="${WORKDIR}"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
-fi
-
-DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
-HOMEPAGE="https://aomedia.org"
-
-LICENSE="BSD-2"
-SLOT="0/2"
-IUSE="doc examples"
-IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
-IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
-IUSE="${IUSE} cpu_flags_arm_neon"
-
-REQUIRED_USE="
- cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
- cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
-"
-
-BDEPEND="abi_x86_32? ( dev-lang/yasm )
- abi_x86_64? ( dev-lang/yasm )
- abi_x86_x32? ( dev-lang/yasm )
- doc? ( app-doc/doxygen )
-"
-
-# the PATENTS file is required to be distributed with this package bug #682214
-DOCS=( PATENTS )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
- -DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
- -DENABLE_NASM=OFF
- -DENABLE_TESTS=OFF
- -DENABLE_TOOLS=ON
- -DENABLE_WERROR=OFF
-
- # neon support is assumed to be always enabled on arm64
- -DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
- # ENABLE_DSPR2 / ENABLE_MSA for mips
- -DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
- -DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
- -DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
- -DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)
- -DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)
- -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
- -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2 ON OFF)
- -DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
- -DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
- )
- cmake_src_configure
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use doc ; then
- local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
- fi
- cmake_src_install
-}
-
-multilib_src_install_all() {
- find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
-}