summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/lcms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/lcms')
-rw-r--r--media-libs/lcms/Manifest2
-rw-r--r--media-libs/lcms/files/lcms-2.6-cve-2014-0459.patch92
-rw-r--r--media-libs/lcms/lcms-2.6-r1.ebuild48
-rw-r--r--media-libs/lcms/lcms-2.7.ebuild46
-rw-r--r--media-libs/lcms/metadata.xml8
5 files changed, 196 insertions, 0 deletions
diff --git a/media-libs/lcms/Manifest b/media-libs/lcms/Manifest
new file mode 100644
index 000000000000..e9172fa2b2cc
--- /dev/null
+++ b/media-libs/lcms/Manifest
@@ -0,0 +1,2 @@
+DIST lcms2-2.6.tar.gz 4583389 SHA256 5172528839647c54c3da211837225e221be93e4733f5b5e9f57668f7107e14b1 SHA512 af2dd8829a5d8b280688bc247812829c885368951d385a23a1596cf8d0a7aed627c8faa35740073efc51a86ef5c900fc9bdb9dcdfad885fb8b1eae16953f9041 WHIRLPOOL 4fe1be53c48b0928bd474e05613c443eea49570a074d22b71863c485408523116927655b57d86bcb02aca85d9e06c0e26d9ee46bc7c4d746e91e951212de9e59
+DIST lcms2-2.7.tar.gz 6497867 SHA256 4524234ae7de185e6b6da5d31d6875085b2198bc63b1211f7dde6e2d197d6a53 SHA512 9e69ec30efa9d50474808c6ae3d9afb0c5798eaabca0052f82d54efecdc2b58ab40434ee6dee9cd80028597d79a07f6b3b1a73f5293fc444343274eac3e32fd4 WHIRLPOOL 2f5cffcdfdf7258e6825c403bc7e455a57e658a6e54ffc27349cb825a45fdee20979991940c9cc59e8a1e5c50f44f1ea57ba06e09ad534753ea8d24b3e2142b4
diff --git a/media-libs/lcms/files/lcms-2.6-cve-2014-0459.patch b/media-libs/lcms/files/lcms-2.6-cve-2014-0459.patch
new file mode 100644
index 000000000000..aa1b17b24083
--- /dev/null
+++ b/media-libs/lcms/files/lcms-2.6-cve-2014-0459.patch
@@ -0,0 +1,92 @@
+patch is directly taken from upstream at
+ https://github.com/mm2/Little-CMS/commit/74ba39195a0cf87c43f46a2fabd9c2168692822d
+original version
+ http://hg.openjdk.java.net/jdk8u/jdk8u/jdk/rev/d6739b8326a4
+cleaned from parts of an accidental commit of unrelated changes.
+
+--- a/src/cmscnvrt.c
++++ b/src/cmscnvrt.c
+@@ -1045,7 +1045,7 @@
+ if (TheIntents[i] == INTENT_PERCEPTUAL || TheIntents[i] == INTENT_SATURATION) {
+
+ // Force BPC for V4 profiles in perceptual and saturation
+- if (cmsGetProfileVersion(hProfiles[i]) >= 4.0)
++ if (cmsGetEncodedICCversion(hProfiles[i]) >= 0x4000000)
+ BPC[i] = TRUE;
+ }
+ }
+--- a/src/cmsintrp.c
++++ b/src/cmsintrp.c
+@@ -929,7 +929,7 @@
+
+ Rest = c1 * rx + c2 * ry + c3 * rz;
+
+- Tmp1[OutChan] = (cmsUInt16Number) c0 + ROUND_FIXED_TO_INT(_cmsToFixedDomain(Rest));
++ Tmp1[OutChan] = (cmsUInt16Number) ( c0 + ROUND_FIXED_TO_INT(_cmsToFixedDomain(Rest)));
+ }
+
+
+@@ -993,7 +993,7 @@
+
+ Rest = c1 * rx + c2 * ry + c3 * rz;
+
+- Tmp2[OutChan] = (cmsUInt16Number) c0 + ROUND_FIXED_TO_INT(_cmsToFixedDomain(Rest));
++ Tmp2[OutChan] = (cmsUInt16Number) (c0 + ROUND_FIXED_TO_INT(_cmsToFixedDomain(Rest)));
+ }
+
+
+--- a/src/cmsio0.c
++++ b/src/cmsio0.c
+@@ -623,6 +623,32 @@
+ }
+
+
++
++// Enforces that the profile version is per. spec.
++// Operates on the big endian bytes from the profile.
++// Called before converting to platform endianness.
++// Byte 0 is BCD major version, so max 9.
++// Byte 1 is 2 BCD digits, one per nibble.
++// Reserved bytes 2 & 3 must be 0.
++static
++cmsUInt32Number _validatedVersion(cmsUInt32Number DWord)
++{
++ cmsUInt8Number* pByte = (cmsUInt8Number*) &DWord;
++ cmsUInt8Number temp1;
++ cmsUInt8Number temp2;
++
++ if (*pByte > 0x09) *pByte = (cmsUInt8Number) 0x09;
++ temp1 = *(pByte+1) & 0xf0;
++ temp2 = *(pByte+1) & 0x0f;
++ if (temp1 > 0x90) temp1 = 0x90;
++ if (temp2 > 0x09) temp2 = 0x09;
++ *(pByte+1) = (cmsUInt8Number)(temp1 | temp2);
++ *(pByte+2) = (cmsUInt8Number)0;
++ *(pByte+3) = (cmsUInt8Number)0;
++
++ return DWord;
++}
++
+ // Read profile header and validate it
+ cmsBool _cmsReadHeader(_cmsICCPROFILE* Icc)
+ {
+@@ -657,7 +683,7 @@
+ Icc -> creator = _cmsAdjustEndianess32(Header.creator);
+
+ _cmsAdjustEndianess64(&Icc -> attributes, &Header.attributes);
+- Icc -> Version = _cmsAdjustEndianess32(Header.version);
++ Icc -> Version = _cmsAdjustEndianess32(_validatedVersion(Header.version));
+
+ // Get size as reported in header
+ HeaderSize = _cmsAdjustEndianess32(Header.size);
+--- a/src/cmsio1.c
++++ b/src/cmsio1.c
+@@ -906,7 +906,7 @@
+ {
+ if (!cmsWriteTag(hProfile, cmsSigProfileSequenceDescTag, seq)) return FALSE;
+
+- if (cmsGetProfileVersion(hProfile) >= 4.0) {
++ if (cmsGetEncodedICCversion(hProfile) >= 0x4000000) {
+
+ if (!cmsWriteTag(hProfile, cmsSigProfileSequenceIdTag, seq)) return FALSE;
+ }
diff --git a/media-libs/lcms/lcms-2.6-r1.ebuild b/media-libs/lcms/lcms-2.6-r1.ebuild
new file mode 100644
index 000000000000..1b93405bef7f
--- /dev/null
+++ b/media-libs/lcms/lcms-2.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
+inherit autotools-multilib
+
+DESCRIPTION="A lightweight, speed optimized color management engine"
+HOMEPAGE="http://www.littlecms.com/"
+SRC_URI="mirror://sourceforge/${PN}/lcms2-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc jpeg static-libs +threads test tiff zlib"
+
+RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-4.0.3-r6:0=[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r10
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/lcms2-${PV}
+
+PATCHES=( "${FILESDIR}"/lcms-2.6-cve-2014-0459.patch )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with jpeg)
+ $(use_with tiff)
+ $(use_with zlib)
+ $(use_with threads)
+ )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ if use doc; then
+ docinto pdf
+ dodoc doc/*.pdf
+ fi
+}
diff --git a/media-libs/lcms/lcms-2.7.ebuild b/media-libs/lcms/lcms-2.7.ebuild
new file mode 100644
index 000000000000..bdb468e992bf
--- /dev/null
+++ b/media-libs/lcms/lcms-2.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
+inherit autotools-multilib
+
+DESCRIPTION="A lightweight, speed optimized color management engine"
+HOMEPAGE="http://www.littlecms.com/"
+SRC_URI="mirror://sourceforge/${PN}/lcms2-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc jpeg static-libs +threads test tiff zlib"
+
+RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-4.0.3-r6:0=[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r10
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/lcms2-${PV}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with jpeg)
+ $(use_with tiff)
+ $(use_with zlib)
+ $(use_with threads)
+ )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ if use doc; then
+ docinto pdf
+ dodoc doc/*.pdf
+ fi
+}
diff --git a/media-libs/lcms/metadata.xml b/media-libs/lcms/metadata.xml
new file mode 100644
index 000000000000..65b8a18eb022
--- /dev/null
+++ b/media-libs/lcms/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+ <upstream>
+ <remote-id type="sourceforge">lcms</remote-id>
+ </upstream>
+</pkgmetadata>