summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2020-09-08 18:45:29 -0300
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-08 00:56:51 +0100
commit4b7f80d7076db0877dc50853adb4ef7db68238d4 (patch)
tree40f00f540ba105e78bcaa9c131c4d834fd1c3b3d /media-libs/kimageannotator/files
parentmedia-libs/kcolorpicker: New package (diff)
downloadgentoo-4b7f80d7076db0877dc50853adb4ef7db68238d4.tar.gz
gentoo-4b7f80d7076db0877dc50853adb4ef7db68238d4.tar.bz2
gentoo-4b7f80d7076db0877dc50853adb4ef7db68238d4.zip
media-libs/kimageannotator: New package
This package (and media-libs/kcolorpicker) will soon be dependencies of kde-apps/spectacle to add annotation capabilities. I have been maintaining both in the GURU overlay since about May 2020. Suggested-by: Andreas Sturmlechner <asturm@gentoo.org> Bug: https://bugs.gentoo.org/723758 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/kimageannotator/files')
-rw-r--r--media-libs/kimageannotator/files/kimageannotator-0.4.0-fix-static-test-library-PR195.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/kimageannotator/files/kimageannotator-0.4.0-fix-static-test-library-PR195.patch b/media-libs/kimageannotator/files/kimageannotator-0.4.0-fix-static-test-library-PR195.patch
new file mode 100644
index 000000000000..7944118641c3
--- /dev/null
+++ b/media-libs/kimageannotator/files/kimageannotator-0.4.0-fix-static-test-library-PR195.patch
@@ -0,0 +1,25 @@
+From 25f13f3058c79e3f4a2b1cd257b213f102931cc3 Mon Sep 17 00:00:00 2001
+From: Dave Flogeras <dflogeras2@gmail.com>
+Date: Wed, 6 Jan 2021 20:07:20 -0400
+Subject: [PATCH] Make test static library explicitly link against kColorPicker
+ and X11.
+
+This was broken when those libraries were made part of a PRIVATE
+interface by bbc2b6595 and af2ff6167.
+---
+ tests/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index b1ecc8a..9918010 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -56,7 +56,7 @@ set(TESTUTILS_SRC
+
+ add_library(KIMAGEANNOTATOR_STATIC STATIC ${KIMAGEANNOTATOR_SRCS})
+
+-target_link_libraries(KIMAGEANNOTATOR_STATIC Qt5::Widgets Qt5::Svg kImageAnnotator)
++target_link_libraries(KIMAGEANNOTATOR_STATIC Qt5::Widgets Qt5::Svg kImageAnnotator kColorPicker::kColorPicker X11)
+
+ target_compile_definitions(KIMAGEANNOTATOR_STATIC PRIVATE KIMAGEANNOTATOR_LANG_INSTALL_DIR="${KIMAGEANNOTATOR_LANG_INSTALL_DIR}")
+