summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/jbig2enc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/jbig2enc')
-rw-r--r--media-libs/jbig2enc/Manifest1
-rw-r--r--media-libs/jbig2enc/files/jbig2enc-0.28-leptonica-1.70.patch52
-rw-r--r--media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild32
-rw-r--r--media-libs/jbig2enc/metadata.xml14
4 files changed, 99 insertions, 0 deletions
diff --git a/media-libs/jbig2enc/Manifest b/media-libs/jbig2enc/Manifest
new file mode 100644
index 000000000000..16e27623d393
--- /dev/null
+++ b/media-libs/jbig2enc/Manifest
@@ -0,0 +1 @@
+DIST jbig2enc-0.28.tar.gz 39879 SHA256 c7c876805403696f3f713b3930c9cc055061ef780201727fa3fcb34f062d4661 SHA512 81d194fb648fe7a866302796fd5e2adbb213d52193a279a94dbc5918ce3480561ea204e8497125eed5d6c6e4c6d089f7f35a89ef98bc484ca753ffde23e444c6 WHIRLPOOL 284b8737285a6181c01d2df788e5ca3ad00b927d176528cfcab228c982ad3503405bc2177f4a10e9d39cc3e96fbedcd5e2f1539c040f05e396f84fda88b931c3
diff --git a/media-libs/jbig2enc/files/jbig2enc-0.28-leptonica-1.70.patch b/media-libs/jbig2enc/files/jbig2enc-0.28-leptonica-1.70.patch
new file mode 100644
index 000000000000..e2ed771d2045
--- /dev/null
+++ b/media-libs/jbig2enc/files/jbig2enc-0.28-leptonica-1.70.patch
@@ -0,0 +1,52 @@
+From 53ce5fe7e73d7ed95c9e12b52dd4984723f865fa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zdenko=20Podobn=C3=BD?= <zdenop@gmail.com>
+Date: Sun, 6 Apr 2014 21:25:27 +0200
+Subject: [PATCH] fix build with leptonica 1.70
+
+Merged upstream
+
+---
+ configure.ac | 1 +
+ src/jbig2.cc | 13 +++++++++----
+ 2 files changed, 10 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fe37c22..753a607 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,6 +55,7 @@ AC_CHECK_LIB([lept], [findFileFormatStream], [], [
+ echo "Error! Leptonica not detected."
+ exit -1
+ ])
++AC_CHECK_FUNCS(expandBinaryPower2Low,,)
+ # test for function - it should detect leptonica dependecies
+
+ # Check for possible dependancies of leptonica.
+diff --git a/src/jbig2.cc b/src/jbig2.cc
+index e10f042..515c1ef 100644
+--- a/src/jbig2.cc
++++ b/src/jbig2.cc
+@@ -130,11 +130,16 @@ segment_image(PIX *pixb, PIX *piximg) {
+ // input color image, so we have to do it this way...
+ // is there a better way?
+ // PIX *pixd = pixExpandBinary(pixd4, 4);
+- PIX *pixd = pixCreate(piximg->w, piximg->h, 1);
+- pixCopyResolution(pixd, piximg);
+- if (verbose) pixInfo(pixd, "mask image: ");
+- expandBinaryPower2Low(pixd->data, pixd->w, pixd->h, pixd->wpl,
++ PIX *pixd;
++#ifdef HAVE_EXPANDBINARYPOWER2LOW
++ pixd = pixCreate(piximg->w, piximg->h, 1);
++ pixCopyResolution(pixd, piximg);
++ expandBinaryPower2Low(pixd->data, pixd->w, pixd->h, pixd->wpl,
+ pixd4->data, pixd4->w, pixd4->h, pixd4->wpl, 4);
++#else
++ pixd = pixExpandBinaryPower2(pixd4, 4);
++#endif
++ if (verbose) pixInfo(pixd, "mask image: ");
+
+ pixDestroy(&pixd4);
+ pixDestroy(&pixsf4);
+--
+2.0.3
+
diff --git a/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild b/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
new file mode 100644
index 000000000000..361bc7c3f9ca
--- /dev/null
+++ b/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="JBIG2 Encoder and libs"
+HOMEPAGE="https://github.com/agl/jbig2enc"
+SRC_URI="https://github.com/agl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="media-libs/leptonica[gif?,jpeg?,png?,tiff?,webp?]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-leptonica-1.70.patch" )
+
+src_prepare() {
+ # remove -Werror
+ sed -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac || die 'sed on configure.ac failed'
+ # prevent static linking and QA notice about insecure RUNPATHs
+ sed -i -e '/jbig2_LDFLAGS/d' src/Makefile.am || die 'sed on src/Makefile.am failed'
+
+ autotools-utils_src_prepare
+}
diff --git a/media-libs/jbig2enc/metadata.xml b/media-libs/jbig2enc/metadata.xml
new file mode 100644
index 000000000000..650ea9af5c9b
--- /dev/null
+++ b/media-libs/jbig2enc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <use>
+ <flag name="webp">Add support for WEBP image format</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">agl/jbig2enc</remote-id>
+ </upstream>
+</pkgmetadata>