summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-29 11:43:18 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-29 16:10:15 -0400
commit7b674cdd0997d2106b62d3ef41dbf6db479ea07f (patch)
treef51dabe74ac7c165da4184e9a5d5bdd7f57b78a4 /media-libs/ilmbase
parentmedia-libs/celt: bump EAPI (diff)
downloadgentoo-7b674cdd0997d2106b62d3ef41dbf6db479ea07f.tar.gz
gentoo-7b674cdd0997d2106b62d3ef41dbf6db479ea07f.tar.bz2
gentoo-7b674cdd0997d2106b62d3ef41dbf6db479ea07f.zip
media-libs/ilmbase: bump EAPI and drop eutils
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs/ilmbase')
-rw-r--r--media-libs/ilmbase/files/ilmbase-1.0.0-asneeded.patch4
-rw-r--r--media-libs/ilmbase/files/ilmbase-1.0.2-gcc43.patch4
-rw-r--r--media-libs/ilmbase/ilmbase-1.0.2.ebuild20
3 files changed, 15 insertions, 13 deletions
diff --git a/media-libs/ilmbase/files/ilmbase-1.0.0-asneeded.patch b/media-libs/ilmbase/files/ilmbase-1.0.0-asneeded.patch
index dc69fb983636..a3953efd3513 100644
--- a/media-libs/ilmbase/files/ilmbase-1.0.0-asneeded.patch
+++ b/media-libs/ilmbase/files/ilmbase-1.0.0-asneeded.patch
@@ -1,5 +1,5 @@
---- IlmThread/Makefile.in
-+++ IlmThread/Makefile.in
+--- a/IlmThread/Makefile.in
++++ b/IlmThread/Makefile.in
@@ -209,7 +209,7 @@
IlmThreadMutexPosix.cpp
diff --git a/media-libs/ilmbase/files/ilmbase-1.0.2-gcc43.patch b/media-libs/ilmbase/files/ilmbase-1.0.2-gcc43.patch
index d822092254d8..a4e186058fe8 100644
--- a/media-libs/ilmbase/files/ilmbase-1.0.2-gcc43.patch
+++ b/media-libs/ilmbase/files/ilmbase-1.0.2-gcc43.patch
@@ -1,5 +1,5 @@
---- Imath/ImathMatrix.h
-+++ Imath/ImathMatrix.h
+--- a/Imath/ImathMatrix.h
++++ b/Imath/ImathMatrix.h
@@ -37,6 +37,8 @@
#ifndef INCLUDED_IMATHMATRIX_H
#define INCLUDED_IMATHMATRIX_H
diff --git a/media-libs/ilmbase/ilmbase-1.0.2.ebuild b/media-libs/ilmbase/ilmbase-1.0.2.ebuild
index eb979ea8ca4c..b92d275e1df2 100644
--- a/media-libs/ilmbase/ilmbase-1.0.2.ebuild
+++ b/media-libs/ilmbase/ilmbase-1.0.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils libtool
+EAPI=6
+inherit libtool
DESCRIPTION="OpenEXR ILM Base libraries"
HOMEPAGE="http://openexr.com/"
@@ -16,20 +16,22 @@ IUSE="static-libs"
RDEPEND="!<media-libs/openexr-1.5.0"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-asneeded.patch"
+ "${FILESDIR}/${P}-gcc43.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0.0-asneeded.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ default
elibtoolize
}
src_configure() {
econf \
- --disable-dependency-tracking \
$(use_enable static-libs static)
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
- find "${D}" -name '*.la' -delete
+ default
+ find "${D}" -name '*.la' -delete || die "Pruning failed"
}