summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2020-07-03 10:40:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-21 20:58:24 +0200
commit29037efa093476fc15dc6261827f29c4b8fff29f (patch)
treec80eb50a0345769650e1b0dc6869df1f891eb2ad /media-libs/ilmbase
parentapp-backup/bacula: Drop old (diff)
downloadgentoo-29037efa093476fc15dc6261827f29c4b8fff29f.tar.gz
gentoo-29037efa093476fc15dc6261827f29c4b8fff29f.tar.bz2
gentoo-29037efa093476fc15dc6261827f29c4b8fff29f.zip
media-libs/ilmbase: bump to 2.5.2
The bump switches to EAPI 7 and uses cmake instead of autotools. Although autotools is currently still supported upstream, they have switched to default cmake build system starting with 2.4. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14832 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/ilmbase')
-rw-r--r--media-libs/ilmbase/Manifest1
-rw-r--r--media-libs/ilmbase/ilmbase-2.5.2.ebuild47
-rw-r--r--media-libs/ilmbase/metadata.xml7
3 files changed, 54 insertions, 1 deletions
diff --git a/media-libs/ilmbase/Manifest b/media-libs/ilmbase/Manifest
index b89e75e82596..57134a0ad812 100644
--- a/media-libs/ilmbase/Manifest
+++ b/media-libs/ilmbase/Manifest
@@ -1 +1,2 @@
DIST ilmbase-2.3.0.tar.gz 595490 BLAKE2B db956fe7dbabf94632eb98635f4ebda8e937f26e26ed69f33743069fa2bf6d5ed3711f00eb33377c98b4f8ea367bbfc51b11d4cb884ce02238b537857cc19a9c SHA512 db0804a7c37c2a97f9dbf81b20f40f7fdea73242baa2759d9dc3728e6849e7ecae0e178fa1c710add980d050499151650675e4b2cda6cbbaa61aca406a1f929a
+DIST ilmbase-2.5.2.tar.gz 27525326 BLAKE2B c48a61513457f2c04f3a512963ae27eaf154933ffe7c6ff3e2d71f27f246ae624a34dbe6f8ab500c51a56898ad0f61e6784f5cd3f9c3df591ce347b46ba4ac88 SHA512 62f98695cf56600303db9c2d13d34cacc1851a103d8ffb7e7ce8c6d9d14e6bf02804836c718ae03e8d685ef3dda0cf7b2130e2d363f8095b22a15bf30d706fab
diff --git a/media-libs/ilmbase/ilmbase-2.5.2.ebuild b/media-libs/ilmbase/ilmbase-2.5.2.ebuild
new file mode 100644
index 000000000000..86af59f34b93
--- /dev/null
+++ b/media-libs/ilmbase/ilmbase-2.5.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="OpenEXR ILM Base libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/25" # based on SONAME
+KEYWORDS="~amd64 -arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="large-stack static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/openexr-${PV}/IlmBase"
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/IlmBaseConfigInternal.h )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DILMBASE_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
+ -DILMBASE_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DILMBASE_INSTALL_PKG_CONFIG=ON
+ )
+
+ # Disable use of ucontext.h wrt #482890
+ if use hppa || use ppc || use ppc64; then
+ mycmakeargs+=(
+ -DILMBASE_HAVE_UCONTEXT_H=OFF
+ )
+ fi
+
+ # needed for running tests with x86_32
+ # see https://github.com/AcademySoftwareFoundation/openexr/issues/346
+ if use abi_x86_32 && use test; then
+ append-cppflags -ffloat-store
+ fi
+
+ cmake_src_configure
+}
diff --git a/media-libs/ilmbase/metadata.xml b/media-libs/ilmbase/metadata.xml
index fc9e500d69e1..d35a747b7c6a 100644
--- a/media-libs/ilmbase/metadata.xml
+++ b/media-libs/ilmbase/metadata.xml
@@ -4,7 +4,12 @@
<maintainer type="project">
<email>media-video@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="large-stack">
+ Enables code to take advantage of large stack support
+ </flag>
+ </use>
<upstream>
- <remote-id type="github">openexr/openexr</remote-id>
+ <remote-id type="github">AcademySoftwareFoundation/openexr</remote-id>
</upstream>
</pkgmetadata>