summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-08-13 20:36:31 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-08-13 20:37:46 +0100
commit2edf7c8d07255dc54c3b0ef1600776eaf4253e92 (patch)
tree81e379be37b0850acf12a69dcebb29ac2a41148e /media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild
parentsys-boot/grub: simplify QA variables (diff)
downloadgentoo-2edf7c8d07255dc54c3b0ef1600776eaf4253e92.tar.gz
gentoo-2edf7c8d07255dc54c3b0ef1600776eaf4253e92.tar.bz2
gentoo-2edf7c8d07255dc54c3b0ef1600776eaf4253e92.zip
media-libs/hal-flash: Conversion to multilib, dependency fixes
The configure script is now included in the tarball. The patch to fix building outside of the source tree has been submitted upstream. Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild')
-rw-r--r--media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild b/media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..ae2499bafb74
--- /dev/null
+++ b/media-libs/hal-flash/hal-flash-0.3.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="libhal stub forwarding to UDisks for Adobe Flash to play DRM content"
+HOMEPAGE="https://github.com/cshorler/hal-flash http://build.opensuse.org/package/show/devel:openSUSE:Factory/hal-flash"
+SRC_URI="http://github.com/cshorler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="dev-libs/glib:2=[${MULTILIB_USEDEP},dbus]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ !sys-apps/hal"
+
+RDEPEND="${COMMON_DEPEND}
+ sys-fs/udisks"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+ECONF_SOURCE="${S}"
+DOCS="FAQ.txt README"
+PATCHES=( "${FILESDIR}"/0001-Make-build-work-outside-of-source-tree.patch )
+
+src_install() {
+ multilib-minimal_src_install
+ prune_libtool_files
+}