summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-10-25 11:03:22 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-10-25 18:31:20 +0100
commitb4ebb73ceaf662ed797ccb6307089117a5037084 (patch)
tree1ab93e04f1bada352855f3eef532ff5bd623506b /media-libs/gstreamer
parentsci-geosciences/opencpn-plugin-statusbar: Support wxGTK:3.0 (diff)
downloadgentoo-b4ebb73ceaf662ed797ccb6307089117a5037084.tar.gz
gentoo-b4ebb73ceaf662ed797ccb6307089117a5037084.tar.bz2
gentoo-b4ebb73ceaf662ed797ccb6307089117a5037084.zip
media-libs/gstreamer: version bump to 1.6.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.6.0.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index 19eaed0507b8..32f6114413c7 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -1,3 +1,4 @@
DIST gstreamer-0.10.36.tar.xz 3025876 SHA256 9151aa108c177054387885763fa0e433e76780f7c5655c70a5390f2a6c6871da SHA512 7468abb578398681d2adb0e9bbc9ee8ae25aaef72369d45a66ada6c67d1759afdce606cb32e68d9e30ae813196bdfef3d4d33202bc77839cc1fbf5fc436c1bd8 WHIRLPOOL 03b841624552be860d4bf824bde9d6d5d6afc629048244b02037c96370c88191f34a6d09f02af61f295a9d6f84952efec2c5d4b0a28e8e70cd17966ed1b01d93
DIST gstreamer-1.2.4.tar.xz 3225208 SHA256 1e7ca67a7870a82c9ed51d51d0008cdbc550c41d64cc3ff3f9a1c2fc311b4929 SHA512 e1feaae567e5dba23270b87bc031b9ba061f664b83a3f18064b8abf802ce3ae6855c97df7a9cb8d861c3c6668e671144da859ae9cda663e88720602198f6f8fc WHIRLPOOL 8c8325ee24d2fe6bb218e6d2cc8e3a2870ac47fb2134914205490decf6593c54ca59f92c95a3da0c7f4eb656191ae9b70a40ae02df87ba64a9c39e9e82fd36c0
DIST gstreamer-1.4.5.tar.xz 3324052 SHA256 40801aa7f979024526258a0e94707ba42b8ab6f7d2206e56adbc4433155cb0ae SHA512 ed7b371f99b7da4ec462e34cd8e02062a0faaad7498a87cfc1ef39f8740db9bca0cc5bfe17ae5ff24abe0bd4a6771e732da193c01ca0e2d835b6c5d9f0d41403 WHIRLPOOL 3065b43a84d8d1d09ec9fb9bda5afc91550cd9f55e2db486c6aceec8fa41dd5ae7d3809c6b6249e86e658c94ffed6ec5a4a7a3cd25b2ab17c24c5a3488355bee
+DIST gstreamer-1.6.0.tar.xz 3549712 SHA256 52ef885647afef11c8b7645a9afefe04aa09e8971c4b932e7717872ab8a30fcc SHA512 8e8b5b0ef4e2c74c1f518c11de19c66cd28faac8036321a5de364b774c7d519b6772c41896d61a67a1df76b256183b42b8496175ae03105bd7f506aa748efe5f WHIRLPOOL 2f8b3c4e6ec81d86bba2dd65db87a11ecd0393da78c863f42fed5282f69fa17fef61a0a913c1d125103f02475d428f918a71ac8f3b0ae5bcf41d1b56d50310bf
diff --git a/media-libs/gstreamer/gstreamer-1.6.0.ebuild b/media-libs/gstreamer/gstreamer-1.6.0.ebuild
new file mode 100644
index 000000000000..ecba53c07fa0
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.6.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib multilib-minimal pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection nls +orc test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ caps? ( sys-libs/libcap )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/bison
+ sys-devel/flex
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( sys-devel/gettext )
+"
+# gtk-doc-am to install API docs
+
+src_configure() {
+ if [[ ${CHOST} == *-interix* ]] ; then
+ export ac_cv_lib_dl_dladdr=no
+ export ac_cv_func_poll=no
+ fi
+ if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
+ # GCC groks this, but then refers to an implementation (___multi3,
+ # ___udivti3) that don't exist (at least I can't find it), so force
+ # this one to be off, such that we use 2x64bit emulation code.
+ export gst_cv_uint128_t=no
+ fi
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # Set 'libexecdir' to ABI-specific location for the library spawns
+ # helpers from there.
+ # Disable static archives, dependency tracking and examples
+ # to speed up build time
+ # Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --disable-debug
+ --disable-examples
+ --disable-static
+ --disable-valgrind
+ --enable-check
+ $(multilib_native_use_enable introspection)
+ $(use_enable nls)
+ $(use_enable test tests)
+ --with-package-name="GStreamer ebuild for Gentoo"
+ --with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer"
+ )
+
+ if use caps ; then
+ myconf+=( --with-ptp-helper-permissions=capabilities )
+ else
+ myconf+=(
+ --with-ptp-helper-permissions=setuid-root
+ --with-ptp-helper-setuid-user=nobody
+ --with-ptp-helper-setuid-group=nobody
+ )
+ fi
+
+ ECONF_SOURCE="${S}" econf ${myconf[$@]}
+
+ if multilib_is_native_abi; then
+ local x
+ for x in gst libs plugins; do
+ ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+ done
+ fi
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ emake DESTDIR="${D}" install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
+}