summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-11-23 15:58:29 -0500
committerMatt Turner <mattst88@gentoo.org>2024-11-23 16:16:05 -0500
commite06b1d9f1ba28167051d9421c15a34a739770df6 (patch)
tree64d0aa29838a9aff486e6717ddbb3378a69b0cef /media-libs/gmmlib
parentdev-ml/gen: Keyword 1.1 arm64, #944753 (diff)
downloadgentoo-e06b1d9f1ba28167051d9421c15a34a739770df6.tar.gz
gentoo-e06b1d9f1ba28167051d9421c15a34a739770df6.tar.bz2
gentoo-e06b1d9f1ba28167051d9421c15a34a739770df6.zip
media-libs/gmmlib: Version bump to 22.5.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/gmmlib')
-rw-r--r--media-libs/gmmlib/Manifest1
-rw-r--r--media-libs/gmmlib/gmmlib-22.5.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/gmmlib/Manifest b/media-libs/gmmlib/Manifest
index 7a9f577d5919..b04239406264 100644
--- a/media-libs/gmmlib/Manifest
+++ b/media-libs/gmmlib/Manifest
@@ -1,2 +1,3 @@
DIST intel-gmmlib-22.5.2.tar.gz 867665 BLAKE2B 64559ec6489614df352ba58d25f8706c234f3cff008228a7056e29d92584fab27af311fdb3db8c2e4f6983598019c646df8761ed422a47bcdbff02e79896d613 SHA512 516e2cc0d678d8fd44d8d2b1bfdf61c05670c01c906bd7f55a807846cd6399d4b616f86e6a1d85e2a6a0480c4616a40e9d5b29a3f45fbf588cc4d725ada71d49
DIST intel-gmmlib-22.5.3.tar.gz 867696 BLAKE2B e7fe7394e0e4ee319a35a551908649e209c28f62fc566eab522f7182a78771b35a58ae067118f198eaca2d4f9cbbf58e4f54b9c838b87eed6ac82f2dce7158f1 SHA512 6649f241096b3b81a63c7d29b42494f5621dd9988f2570eaeb7164a4e5a71083180d4a8634782c4831ab8cd22e6b736a2e45e1a52cd5b70f62fe892411362444
+DIST intel-gmmlib-22.5.4.tar.gz 868826 BLAKE2B 8a3d455a271d2e76e790e980e96ab0d9bd70854c039272b34eb605d8175749a9a561178ec022d197960bb4e9226217ed43c1a53f2598b1c6910931ca35d4c1c1 SHA512 08735c056a443f5f998b089e8a88bb61f1b0ceb2557971af3c9a0235aca3846888bd32ec42a9750e311d0575a84111c897a6417bcaf3ecf0eac60fa2549f5d93
diff --git a/media-libs/gmmlib/gmmlib-22.5.4.ebuild b/media-libs/gmmlib/gmmlib-22.5.4.ebuild
new file mode 100644
index 000000000000..2a09f24b8f3d
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.5.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+ S="${WORKDIR}/${PN}-intel-${P}"
+fi
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+
+LICENSE="MIT"
+SLOT="0/12.3"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}