summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-10-19 10:28:52 +0000
committerYixun Lan <dlan@gentoo.org>2023-12-04 02:53:47 +0000
commit0740e712cdeb2e2c39f86dabbfa6d4683ee78d85 (patch)
tree41ab2934277882a64b8435c1c6ef0d6c85657bfd /media-libs/exiftool
parentnet-analyzer/goaccess: add 1.8.1 (diff)
downloadgentoo-0740e712cdeb2e2c39f86dabbfa6d4683ee78d85.tar.gz
gentoo-0740e712cdeb2e2c39f86dabbfa6d4683ee78d85.tar.bz2
gentoo-0740e712cdeb2e2c39f86dabbfa6d4683ee78d85.zip
media-libs/exiftool: add 12.68
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'media-libs/exiftool')
-rw-r--r--media-libs/exiftool/Manifest1
-rw-r--r--media-libs/exiftool/exiftool-12.68.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/exiftool/Manifest b/media-libs/exiftool/Manifest
index d05df2db34e8..f7e5a6bb096c 100644
--- a/media-libs/exiftool/Manifest
+++ b/media-libs/exiftool/Manifest
@@ -3,3 +3,4 @@ DIST Image-ExifTool-12.60.tar.gz 5204922 BLAKE2B 6b4012d722153756a1bb289422d5546
DIST Image-ExifTool-12.61.tar.gz 5207863 BLAKE2B 814cc48ef7d89ea64f22e480964ba7ba9613feb3213420a594b141353a269990e2651a899326cfcd88c387ac810e6e1b4ae817903ae9353b7ee21bef75cf8306 SHA512 bf45b6f838dfe04c5820eb7b1ab65a74b8e2079d56be7ae0382d6c88965f5506cd8e4331232531fdf28d9bf4ebd5b649d0d2afc09977b1de923a8f1a7f6955fb
DIST Image-ExifTool-12.62.tar.gz 5216215 BLAKE2B 72c30368ad12036af628210f210f06f5fabfb63c6e2fc3136ae611f305dd654381c7fbd0c84ed8e0fbc3d765a9c5a4814f6380078c7ce9042c52c05d5b433338 SHA512 41d8c9dd9bd3bc784a648a4656133709d3c5b29f1251a2b6122be39cff946d16ef53f6199c858bed96e3661edaab1f14bdd892b213b0be95772f843e0aa8cb23
DIST Image-ExifTool-12.64.tar.gz 5244559 BLAKE2B fffa18a00b87bee679469c5a83851760f600f34131528ad5638a18fbffd9116b1350553681bb0e05eff86fb129cd7eeae30af82c53d00d72c01e2be6ffad485d SHA512 d643787b4c279271b01cee800fd554707cacb57e42955d58c68d4eb4de93b75d8628d724307e812d61a5b780af3f555680d6f3617080c649d532d2492fe67dcf
+DIST Image-ExifTool-12.68.tar.gz 5275783 BLAKE2B 3a04a8371a9e24da350b999ea1a11e2df2910a8e6274e684dc57ea5239a1eab371e4c42e1e1d2cf98dd2bbd436627c8a916322ab9f06fde78e406e28ae9758db SHA512 7b1eeb7854d5dabec5736ec9420abd539655d060abf40f0690a90864829606e1a1e4bf6a2c1c4589a3283aec8e271d983e55a788f919093b65465872da798e6a
diff --git a/media-libs/exiftool/exiftool-12.68.ebuild b/media-libs/exiftool/exiftool-12.68.ebuild
new file mode 100644
index 000000000000..be671cae8267
--- /dev/null
+++ b/media-libs/exiftool/exiftool-12.68.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check https://exiftool.org/history.html for whether a release is 'production'
+# Ideally don't bump to non-production at all, but certainly don't stable.
+
+DIST_NAME=Image-ExifTool
+inherit perl-module
+
+DESCRIPTION="Read and write meta information in image, audio and video files"
+HOMEPAGE="https://exiftool.org/ https://exiftool.sourceforge.net"
+SRC_URI="https://exiftool.org/${DIST_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="doc"
+
+src_install() {
+ perl-module_src_install
+ use doc && dodoc -r html/
+
+ insinto /usr/share/${PN}
+ doins -r fmt_files config_files arg_files
+}