summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2017-07-23 16:08:39 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2017-07-23 16:09:09 +0300
commit91ee8a4e9e3f2d09578d350ef0badd1edf4d4693 (patch)
treebcc5cbe909f2827ddfdd39e2e2836b87948f2083 /media-libs/coin
parentmedia-libs/coin: Fix segfault with GCC-6 (diff)
downloadgentoo-91ee8a4e9e3f2d09578d350ef0badd1edf4d4693.tar.gz
gentoo-91ee8a4e9e3f2d09578d350ef0badd1edf4d4693.tar.bz2
gentoo-91ee8a4e9e3f2d09578d350ef0badd1edf4d4693.zip
media-libs/coin: Now it can be build with gcc7
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-libs/coin')
-rw-r--r--media-libs/coin/coin-3.1.3-r2.ebuild1
-rw-r--r--media-libs/coin/files/coin-3.1.3-gcc-7.patch21
2 files changed, 22 insertions, 0 deletions
diff --git a/media-libs/coin/coin-3.1.3-r2.ebuild b/media-libs/coin/coin-3.1.3-r2.ebuild
index 5edce05a9cb2..6880fa4cc0e9 100644
--- a/media-libs/coin/coin-3.1.3-r2.ebuild
+++ b/media-libs/coin/coin-3.1.3-r2.ebuild
@@ -46,6 +46,7 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc-4.7.patch
"${FILESDIR}"/${P}-freetype251.patch
"${FILESDIR}"/${P}-memhandler-initialization.patch
+ "${FILESDIR}"/${P}-gcc-7.patch
)
DOCS=(
diff --git a/media-libs/coin/files/coin-3.1.3-gcc-7.patch b/media-libs/coin/files/coin-3.1.3-gcc-7.patch
new file mode 100644
index 000000000000..c1f1f560d851
--- /dev/null
+++ b/media-libs/coin/files/coin-3.1.3-gcc-7.patch
@@ -0,0 +1,21 @@
+diff -urN Coin-3.1.3.orig/src/3ds/SoStream.cpp Coin-3.1.3/src/3ds/SoStream.cpp
+--- Coin-3.1.3.orig/src/3ds/SoStream.cpp 2010-03-02 16:20:09.000000000 +0300
++++ Coin-3.1.3/src/3ds/SoStream.cpp 2017-07-23 15:04:43.808204691 +0300
+@@ -176,7 +176,7 @@
+ if (!gotNum) { setBadBit(); return FALSE; } \
+ \
+ char *ce; \
+- s = '\0'; \
++ s = NULL; \
+ _convertType_ tempVal = _convertFunc_(buf, &ce, 0); \
+ \
+ if (ce != s) \
+@@ -273,7 +273,7 @@
+ gotAll: \
+ \
+ char *ce; \
+- s = '\0'; \
++ s = NULL; \
+ double tempVal = _convertFunc_(buf, &ce); \
+ \
+ if (ce != s) \