summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/coin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/coin')
-rw-r--r--media-libs/coin/Manifest1
-rw-r--r--media-libs/coin/coin-3.1.3-r2.ebuild99
-rw-r--r--media-libs/coin/files/coin-3.1.0-javascript.patch38
-rw-r--r--media-libs/coin/files/coin-3.1.3-freetype251.patch28
-rw-r--r--media-libs/coin/files/coin-3.1.3-gcc-4.7.patch10
-rw-r--r--media-libs/coin/files/coin-3.1.3-pkgconfig-partial.patch13
-rw-r--r--media-libs/coin/metadata.xml10
7 files changed, 199 insertions, 0 deletions
diff --git a/media-libs/coin/Manifest b/media-libs/coin/Manifest
new file mode 100644
index 000000000000..f99df3971e47
--- /dev/null
+++ b/media-libs/coin/Manifest
@@ -0,0 +1 @@
+DIST Coin-3.1.3.tar.gz 5981534 SHA256 583478c581317862aa03a19f14c527c3888478a06284b9a46a0155fa5886d417 SHA512 d6fd47ecc74e96fc4de46e3a683f038f1907b96db2bbe935fb49f2d59190bd18f3f439dc0e4cb435360e74e1d65994a32b21f670d5a76394692616625cb14394 WHIRLPOOL 2b02b2273acfe2f5d779d8adaca8f88c5119a3326e395cc039df6898d2c7c60888d7586de877a27fca3a4cb620662ffe9363d845836b2483c2f3108475ea696c
diff --git a/media-libs/coin/coin-3.1.3-r2.ebuild b/media-libs/coin/coin-3.1.3-r2.ebuild
new file mode 100644
index 000000000000..995882361bee
--- /dev/null
+++ b/media-libs/coin/coin-3.1.3-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils flag-o-matic
+
+MY_P=${P/c/C}
+
+DESCRIPTION="A high-level 3D graphics toolkit, fully compatible with SGI Open Inventor 2.1"
+HOMEPAGE="http://www.coin3d.org/"
+SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 PEL )"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="bzip2 debug doc javascript openal simage static-libs threads zlib"
+
+# NOTE: expat is not really needed as --enable-system-expat is broken
+RDEPEND="
+ dev-libs/expat
+ media-libs/fontconfig
+ media-libs/freetype:2
+ virtual/opengl
+ virtual/glu
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ bzip2? ( app-arch/bzip2 )
+ javascript? ( dev-lang/spidermonkey:0 )
+ openal? ( media-libs/openal )
+ simage? ( media-libs/simage )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ doc? ( app-doc/doxygen )
+"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.0-javascript.patch
+ "${FILESDIR}"/${P}-pkgconfig-partial.patch
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ "${FILESDIR}"/${P}-freetype251.patch
+)
+
+DOCS=(
+ AUTHORS FAQ FAQ.legal NEWS README RELNOTES THANKS
+ docs/{ChangeLog.v${PV},HACKING,oiki-launch.txt}
+)
+
+src_configure() {
+ append-cppflags -I"${EPREFIX}/usr/include/freetype2"
+ # Prefer link-time linking over dlopen
+ local myeconfargs=(
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --disable-dl-fontconfig
+ --disable-dl-freetype
+ --disable-dl-libbzip2
+ --disable-dl-openal
+ --disable-dl-simage
+ --disable-dl-zlib
+ --disable-dyld
+ --disable-loadlibrary
+ --disable-man
+ --disable-java-wrapper
+ --enable-3ds-import
+ --enable-compact
+ --enable-dl-glu
+ --enable-dl-spidermonkey
+ --enable-system-expat
+ --includedir="${EPREFIX}/usr/include/${PN}"
+ --with-fontconfig
+ --with-freetype
+ $(use_with bzip2)
+ $(use_enable debug)
+ $(use_enable debug symbols)
+ $(use_enable doc html)
+ $(use_enable javascript javascript-api)
+ $(use_with javascript spidermonkey)
+ $(use_enable openal sound)
+ $(use_with openal)
+ $(use_with simage)
+ $(use_enable threads threadsafe)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ # Remove Coin from Libs.private
+ sed -e '/Libs.private/s/ -lCoin//' -i "${BUILD_DIR}"/Coin.pc || die
+
+ autotools-utils_src_install
+}
diff --git a/media-libs/coin/files/coin-3.1.0-javascript.patch b/media-libs/coin/files/coin-3.1.0-javascript.patch
new file mode 100644
index 000000000000..f45d9cd78cf6
--- /dev/null
+++ b/media-libs/coin/files/coin-3.1.0-javascript.patch
@@ -0,0 +1,38 @@
+Index: src/vrml97/JS_VRMLClasses.h
+===================================================================
+--- src/vrml97/JS_VRMLClasses.h (revision 13505)
++++ src/vrml97/JS_VRMLClasses.h (revision 13506)
+@@ -28,6 +28,7 @@
+ #error this is a private header file
+ #endif /* ! COIN_INTERNAL */
+
++#if defined(HAVE_VRML97) && defined(COIN_HAVE_JAVASCRIPT)
+ /* ********************************************************************** */
+
+ class SoJavaScriptEngine;
+@@ -37,5 +38,6 @@
+ void JS_addVRMLclasses(SoJavaScriptEngine * engine);
+
+ /* ********************************************************************** */
++#endif // HAVE_VRML97 && COIN_HAVE_JAVASCRIPT
+
+ #endif /* !COIN_JS_VRMLCLASSES_H */
+Index: src/vrml97/JS_VRMLClasses.cpp
+===================================================================
+--- src/vrml97/JS_VRMLClasses.cpp (revision 13505)
++++ src/vrml97/JS_VRMLClasses.cpp (revision 13506)
+@@ -2,7 +2,7 @@
+ #include "config.h"
+ #endif // HAVE_CONFIG_H
+
+-#ifdef HAVE_VRML97
++#if defined(HAVE_VRML97) && defined(COIN_HAVE_JAVASCRIPT)
+
+ /**************************************************************************\
+ *
+@@ -2097,4 +2097,4 @@
+ MFVec3dHandler::jsval2field);
+ }
+
+-#endif // HAVE_VRML97
++#endif // HAVE_VRML97 && COIN_HAVE_JAVASCRIPT
diff --git a/media-libs/coin/files/coin-3.1.3-freetype251.patch b/media-libs/coin/files/coin-3.1.3-freetype251.patch
new file mode 100644
index 000000000000..44e8eefb1f63
--- /dev/null
+++ b/media-libs/coin/files/coin-3.1.3-freetype251.patch
@@ -0,0 +1,28 @@
+--- Coin-3.1.3/src/glue/freetype.cpp
++++ Coin-3.1.3/src/glue/freetype.cpp
+@@ -52,9 +52,9 @@
+ #ifdef HAVE_FREETYPE /* In case we're _not_ doing runtime linking. */
+ #define FREETYPEGLUE_ASSUME_FREETYPE 1
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
+ #endif /* FREETYPEGLUE_ASSUME_FREETYPE */
+
+ #include <Inventor/C/basic.h>
+--- Coin-3.1.3/src/glue/freetype.h
++++ Coin-3.1.3/src/glue/freetype.h
+@@ -87,8 +87,8 @@
+
+ #ifdef HAVE_FREETYPE
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
+ #else /* HAVE_FREETYPE */
+
+ #include <Inventor/C/basic.h>
diff --git a/media-libs/coin/files/coin-3.1.3-gcc-4.7.patch b/media-libs/coin/files/coin-3.1.3-gcc-4.7.patch
new file mode 100644
index 000000000000..fd2430903802
--- /dev/null
+++ b/media-libs/coin/files/coin-3.1.3-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- coin3-3.1.3.orig/include/Inventor/SbBasic.h
++++ coin3-3.1.3/include/Inventor/SbBasic.h
+@@ -24,6 +24,7 @@
+ *
+ \**************************************************************************/
+
++#include <Inventor/C/errors/debugerror.h>
+ #include <Inventor/C/basic.h>
+
+ /* ********************************************************************** */
diff --git a/media-libs/coin/files/coin-3.1.3-pkgconfig-partial.patch b/media-libs/coin/files/coin-3.1.3-pkgconfig-partial.patch
new file mode 100644
index 000000000000..3fd3bca726d4
--- /dev/null
+++ b/media-libs/coin/files/coin-3.1.3-pkgconfig-partial.patch
@@ -0,0 +1,13 @@
+diff -ru ../Coin-3.1.3/Coin.pc.in ./Coin.pc.in
+--- Coin.pc.in 2010-03-02 14:20:09.000000000 +0100
++++ Coin.pc.in 2010-06-28 19:27:59.634534460 +0200
+@@ -10,7 +10,8 @@
+ Version: @COIN_VERSION@
+ Requires:
+ Conflicts:
+-Libs: -L${libdir} @COIN_EXTRA_LDFLAGS@ @COIN_EXTRA_LIBS@
++Libs: -L${libdir} -lCoin
++Libs.private: -L${libdir} @COIN_EXTRA_LIBS@
+ Cflags: -I${includedir} @COIN_EXTRA_CFLAGS@ @COIN_EXTRA_CPPFLAGS@
+
+ coin_host=@host@
diff --git a/media-libs/coin/metadata.xml b/media-libs/coin/metadata.xml
new file mode 100644
index 000000000000..82c9c9c00eb8
--- /dev/null
+++ b/media-libs/coin/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>reavertm@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="simage">Texture loading via <pkg>media-libs/simage</pkg> library</flag>
+ </use>
+</pkgmetadata>