summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2020-10-14 02:36:23 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2020-10-14 02:36:23 +0200
commit4485260386ba034842b54a812f87f7133ddbd88f (patch)
tree63f81b5135876ef7efaea8ea048ae3dbd0fdfee4 /media-libs/coin/coin-3.1.3-r2.ebuild
parentdev-libs/injeqt: no Werror (diff)
downloadgentoo-4485260386ba034842b54a812f87f7133ddbd88f.tar.gz
gentoo-4485260386ba034842b54a812f87f7133ddbd88f.tar.bz2
gentoo-4485260386ba034842b54a812f87f7133ddbd88f.zip
media-libs/coin: remove old, update remote-id in metadata.xml
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
Diffstat (limited to 'media-libs/coin/coin-3.1.3-r2.ebuild')
-rw-r--r--media-libs/coin/coin-3.1.3-r2.ebuild100
1 files changed, 0 insertions, 100 deletions
diff --git a/media-libs/coin/coin-3.1.3-r2.ebuild b/media-libs/coin/coin-3.1.3-r2.ebuild
deleted file mode 100644
index 6e2dfe73f617..000000000000
--- a/media-libs/coin/coin-3.1.3-r2.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils flag-o-matic
-
-MY_P=${P/c/C}
-
-DESCRIPTION="A high-level 3D graphics toolkit, fully compatible with SGI Open Inventor 2.1"
-HOMEPAGE="https://bitbucket.org/Coin3D/coin/wiki/Home"
-SRC_URI="https://bitbucket.org/Coin3D/coin/downloads/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 PEL )"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="bzip2 debug doc javascript openal simage static-libs threads zlib"
-
-# NOTE: expat is not really needed as --enable-system-expat is broken
-RDEPEND="
- dev-libs/expat
- media-libs/fontconfig
- media-libs/freetype:2
- virtual/opengl
- virtual/glu
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- bzip2? ( app-arch/bzip2 )
- javascript? ( dev-lang/spidermonkey:0 )
- openal? ( media-libs/openal )
- simage? ( media-libs/simage )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-base/xorg-proto
- doc? ( app-doc/doxygen )
-"
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.0-javascript.patch
- "${FILESDIR}"/${P}-pkgconfig-partial.patch
- "${FILESDIR}"/${P}-gcc-4.7.patch
- "${FILESDIR}"/${P}-freetype251.patch
- "${FILESDIR}"/${P}-memhandler-initialization.patch
- "${FILESDIR}"/${P}-gcc-7.patch
-)
-
-DOCS=(
- AUTHORS FAQ FAQ.legal NEWS README RELNOTES THANKS
- docs/{ChangeLog.v${PV},HACKING,oiki-launch.txt}
-)
-
-src_configure() {
- append-cppflags -I"${EPREFIX}/usr/include/freetype2"
- # Prefer link-time linking over dlopen
- local myeconfargs=(
- htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
- --disable-dl-fontconfig
- --disable-dl-freetype
- --disable-dl-libbzip2
- --disable-dl-openal
- --disable-dl-simage
- --disable-dl-zlib
- --disable-dyld
- --disable-loadlibrary
- --disable-man
- --disable-java-wrapper
- --enable-3ds-import
- --enable-compact
- --enable-dl-glu
- --enable-dl-spidermonkey
- --enable-system-expat
- --includedir="${EPREFIX}/usr/include/${PN}"
- --with-fontconfig
- --with-freetype
- $(use_with bzip2)
- $(use_enable debug)
- $(use_enable debug symbols)
- $(use_enable doc html)
- $(use_enable javascript javascript-api)
- $(use_with javascript spidermonkey)
- $(use_enable openal sound)
- $(use_with openal)
- $(use_with simage)
- $(use_enable threads threadsafe)
- $(use_with zlib)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- # Remove Coin from Libs.private
- sed -e '/Libs.private/s/ -lCoin//' -i "${BUILD_DIR}"/Coin.pc || die
-
- autotools-utils_src_install
-}