summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/clutter-gtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/clutter-gtk')
-rw-r--r--media-libs/clutter-gtk/Manifest2
-rw-r--r--media-libs/clutter-gtk/clutter-gtk-1.6.0-r1.ebuild52
-rw-r--r--media-libs/clutter-gtk/clutter-gtk-1.6.0.ebuild45
-rw-r--r--media-libs/clutter-gtk/clutter-gtk-1.6.2.ebuild45
-rw-r--r--media-libs/clutter-gtk/files/clutter-gtk-1.6.0-clutter_gdk_get_visual.patch34
-rw-r--r--media-libs/clutter-gtk/metadata.xml5
6 files changed, 183 insertions, 0 deletions
diff --git a/media-libs/clutter-gtk/Manifest b/media-libs/clutter-gtk/Manifest
new file mode 100644
index 000000000000..db7ba305891d
--- /dev/null
+++ b/media-libs/clutter-gtk/Manifest
@@ -0,0 +1,2 @@
+DIST clutter-gtk-1.6.0.tar.xz 313240 SHA256 883550b574a036363239442edceb61cf3f6bedc8adc97d3404278556dc82234d SHA512 390f6964722c2e973309464a00ed0f9b2d8af33e2ff35e214ce53009f1f6bec2c5f0810c724ea58ea1321370f2b66f1d392e7dfa0e44817c9dafe29b74981f00 WHIRLPOOL a5a048aa0483d4f8efe5ed9f164d1ab5c64e1244689ea894aed13b627604bb337735681429e3f00266d19b07435a2869c0bc46d4c88be8fd21b5831d908eeb69
+DIST clutter-gtk-1.6.2.tar.xz 314600 SHA256 bbd03dfa9a20102d5cdb440513b0a035933da557ad7e9da31546034de2daf069 SHA512 60e4131878b8db6aa87c3d1cde5f978e61074f5fa471f3a725cbd7e85ea71ddf319eb3a0210683d4403613458badf564e8418e31dce608b16729215ce5e6e068 WHIRLPOOL 2e95063c9463fe7d455a2f800996525c635c58bcf001a82fd25bff0f9779054e247cbe1a66aa8ab1304011061ca42f31234a3bed4badc3ff413ad92283db5916
diff --git a/media-libs/clutter-gtk/clutter-gtk-1.6.0-r1.ebuild b/media-libs/clutter-gtk/clutter-gtk-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..687fcc9adbc1
--- /dev/null
+++ b/media-libs/clutter-gtk/clutter-gtk-1.6.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Library for embedding a Clutter canvas (stage) in GTK+"
+HOMEPAGE="https://wiki.gnome.org/Projects/Clutter"
+LICENSE="LGPL-2.1+"
+
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.6.0:3[introspection?]
+ >=media-libs/clutter-1.22.2-r1:1.0[introspection?]
+ media-libs/cogl:1.0=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # patches from upstream git master
+ epatch "${FILESDIR}"/${P}-clutter_gdk_get_visual.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-maintainer-flags \
+ --enable-deprecated \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,redhand.png}
+ fi
+}
diff --git a/media-libs/clutter-gtk/clutter-gtk-1.6.0.ebuild b/media-libs/clutter-gtk/clutter-gtk-1.6.0.ebuild
new file mode 100644
index 000000000000..394b3ef07ebf
--- /dev/null
+++ b/media-libs/clutter-gtk/clutter-gtk-1.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Library for embedding a Clutter canvas (stage) in GTK+"
+HOMEPAGE="https://wiki.gnome.org/Projects/Clutter"
+LICENSE="LGPL-2.1+"
+
+SLOT="1.0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.6.0:3[introspection?]
+ >=media-libs/clutter-1.18.0:1.0[introspection?]
+ media-libs/cogl:1.0=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-maintainer-flags \
+ --enable-deprecated \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,redhand.png}
+ fi
+}
diff --git a/media-libs/clutter-gtk/clutter-gtk-1.6.2.ebuild b/media-libs/clutter-gtk/clutter-gtk-1.6.2.ebuild
new file mode 100644
index 000000000000..e57ee1d5c1de
--- /dev/null
+++ b/media-libs/clutter-gtk/clutter-gtk-1.6.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Library for embedding a Clutter canvas (stage) in GTK+"
+HOMEPAGE="https://wiki.gnome.org/Projects/Clutter"
+LICENSE="LGPL-2.1+"
+
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.6.0:3[introspection?]
+ >=media-libs/clutter-1.22.3:1.0[introspection?]
+ media-libs/cogl:1.0=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-maintainer-flags \
+ --enable-deprecated \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,redhand.png}
+ fi
+}
diff --git a/media-libs/clutter-gtk/files/clutter-gtk-1.6.0-clutter_gdk_get_visual.patch b/media-libs/clutter-gtk/files/clutter-gtk-1.6.0-clutter_gdk_get_visual.patch
new file mode 100644
index 000000000000..921eb032e5d0
--- /dev/null
+++ b/media-libs/clutter-gtk/files/clutter-gtk-1.6.0-clutter_gdk_get_visual.patch
@@ -0,0 +1,34 @@
+From 60df86a6fbc0f5893fff182b4308c2ee4d679569 Mon Sep 17 00:00:00 2001
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Wed, 10 Jun 2015 12:03:54 +0100
+Subject: [PATCH] embed: Use the GDK visual from Clutter
+
+Instead of relying on the widget one. This is similar to what we do when
+running with the X11 backend.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=747489
+---
+ clutter-gtk/gtk-clutter-embed.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/clutter-gtk/gtk-clutter-embed.c b/clutter-gtk/gtk-clutter-embed.c
+index 64cc8b6..80b5839 100644
+--- a/clutter-gtk/gtk-clutter-embed.c
++++ b/clutter-gtk/gtk-clutter-embed.c
+@@ -327,6 +327,13 @@ gtk_clutter_embed_realize (GtkWidget *widget)
+ gint attributes_mask;
+ gint border_width;
+
++#if defined(CLUTTER_WINDOWING_GDK)
++ if (clutter_check_windowing_backend (CLUTTER_WINDOWING_GDK))
++ {
++ GdkVisual *visual = clutter_gdk_get_visual ();
++ gtk_widget_set_visual (widget, visual);
++ }
++#endif
+ #if defined(GDK_WINDOWING_X11) && defined(CLUTTER_WINDOWING_X11)
+ if (clutter_check_windowing_backend (CLUTTER_WINDOWING_X11))
+ {
+--
+2.4.3
+
diff --git a/media-libs/clutter-gtk/metadata.xml b/media-libs/clutter-gtk/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/media-libs/clutter-gtk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>