summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo75@gmail.com>2019-09-26 12:36:24 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-26 18:48:50 +0300
commit8ff12a58497d55cbde453f2de6ec1d8088724dd1 (patch)
treec4537cc65d3cbc8a5a1b737e819c9d49dbdb6edf /media-gfx
parentdev-libs/aws-c-event-stream: Fix dependencies (#695206) (diff)
downloadgentoo-8ff12a58497d55cbde453f2de6ec1d8088724dd1.tar.gz
gentoo-8ff12a58497d55cbde453f2de6ec1d8088724dd1.tar.bz2
gentoo-8ff12a58497d55cbde453f2de6ec1d8088724dd1.zip
media-gfx/rawtherapee: version bump to 5.7
Signed-off-by: Francesco Riosa <vivo75@gmail.com> Closes: https://bugs.gentoo.org/695408 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Closes: https://github.com/gentoo/gentoo/pull/13046 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/rawtherapee/Manifest1
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.7.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index e45ab3b82ab7..7026f26c132c 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1 +1,2 @@
DIST rawtherapee-5.6.tar.xz 12083264 BLAKE2B a0eb09e98e1041b393ad3aa671641a2a4855379cef6245ca3cca2588ff5f50fedf8becd88bad1ab70f63dfb575f5f22c141040defa10b47268947415999d8e79 SHA512 2c751c7631ea2ef65c334fa0baab16d4c3161fae66487870c476f07f1ea3604a5e28a251fd98d9688cafc088302af7aa6e28e9b27a37f916715708ed5e731f0f
+DIST rawtherapee-5.7.tar.xz 12092496 BLAKE2B 40d97d09106d7d2b843376b4c58daac87f99315604bd8e704e1f231c17d01896cd732da2449f84a59ed221fbf6a929a5db8e728977431fdcc07f3d30120b633a SHA512 8101ec66d9be4cab0c0b91336a3f83a32a6220a2f342f1c74d604c15686ee08bc7dbc090232916f13d5436957d800b64b284a8a9d3352f2f721266b07e005162
diff --git a/media-gfx/rawtherapee/rawtherapee-5.7.ebuild b/media-gfx/rawtherapee/rawtherapee-5.7.ebuild
new file mode 100644
index 000000000000..48b8dca754d1
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/_rc/-rc}
+inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="openmp"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/libsigc++:2
+ media-libs/lcms:2
+ media-libs/lensfun
+ media-libs/libcanberra[gtk3]
+ media-libs/libiptcdata
+ media-libs/libpng:0
+ media-libs/tiff:0
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ virtual/jpeg:0
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-cpp/gtkmm:3.0
+ gnome-base/librsvg"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}