summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-03-25 21:15:07 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-03-25 21:15:07 +0100
commit7b191e39343855bfdd34c4b49d8bfbe7cb22ff81 (patch)
tree4e7f9f0147c39bd9dd4ca8fa8c7f0db97bfc003e /media-gfx
parentmedia-gfx/geeqie: fix musl compilation again (diff)
downloadgentoo-7b191e39343855bfdd34c4b49d8bfbe7cb22ff81.tar.gz
gentoo-7b191e39343855bfdd34c4b49d8bfbe7cb22ff81.tar.bz2
gentoo-7b191e39343855bfdd34c4b49d8bfbe7cb22ff81.zip
media-gfx/geeqie: add 2.4
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/geeqie/Manifest2
-rw-r--r--media-gfx/geeqie/geeqie-2.4.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/media-gfx/geeqie/Manifest b/media-gfx/geeqie/Manifest
index 3aa1c6752ab0..f2a4ecce649a 100644
--- a/media-gfx/geeqie/Manifest
+++ b/media-gfx/geeqie/Manifest
@@ -4,3 +4,5 @@ DIST geeqie-2.2-docs.tar.xz 356976 BLAKE2B 3bca2815a6f177a2f38b9a66ff6fa95dba510
DIST geeqie-2.2.tar.xz 2169096 BLAKE2B fe7f21f5842ac7824ec37f0775d31e8dcd05934809f7bdd84d7dcb749d25976055050f42a8cea3cd414fb3c7e60055c9fa32b93cfef2af62de68f4d44af425c8 SHA512 7d03493b463a1949cbc5e377927abc4bc6fa62914e8cdddb30a832cb9c6caad579f5ba5bd2b8b0913b77063300c9c5ac1f7e671ddfb2ce18d8a8d0efcfb51dbe
DIST geeqie-2.3-docs.tar.xz 362412 BLAKE2B e05adbd6b277cfccae20c2ed7840e447016b32a9bf5c5ad6feb143993b4856fbb623feb6684a21c235ad846923463bed45cf887b1854189f01a46c3961f26a18 SHA512 cab4739adecd1dcb9cde3a58a2e2c2262f4014bc7594ae22af69b8bdbb14f6849b1e2267646301f31ebde76b2b2abc05e75aac3325e35cb88f9dc40703f2d943
DIST geeqie-2.3.tar.xz 2184604 BLAKE2B dbd2d52d146d373a9694a7371a8ac44571e63895cf6cea7acb549a1135b4cf5869737cdf780ca6afdb14eda1338cb275791eaac1cd7596ed58eb07759cf75778 SHA512 9f45974d12c1f193a4a3624064b967fc06cf9c906c45160a4945a8f6a9d814b929b92c45a35006c7f1b20fa5fe360858f24fd54adbcd8863c3e7d787a3429899
+DIST geeqie-2.4-docs.tar.xz 364536 BLAKE2B 688720808c8e4543455259966aef726bf56a821890a78e4757d9d1fd02ce67217461808d9697b331b2a94841bf3581b25242a7e5c9c9a3f5b02209a566b09c16 SHA512 07bca33c347f448ee853ea60daf22c9cdace458b6ce6b3f4ced9b343a965370c51d7a872d5279852b7a83a1de51c8529a668f7d62a031bcec1fdde8b9bfbf9cb
+DIST geeqie-2.4.tar.xz 2178572 BLAKE2B df24f0b5d443cbd2033c0b382fe0d846c9073e8966aa736f647e34930e44083b9e44252c554578548a13c12c1b1a5a48bb7795f2fda8b8688a63ef402a257334 SHA512 7e0f5dff21e38a41adf0a793bd82652c5d639e84ab49403517f4b1dae042bfc5f4d02e54b54928e04a2397300acb04b130347df0be5637ee48634f5865ad346b
diff --git a/media-gfx/geeqie/geeqie-2.4.ebuild b/media-gfx/geeqie/geeqie-2.4.ebuild
new file mode 100644
index 000000000000..2b9b96fbe6a9
--- /dev/null
+++ b/media-gfx/geeqie/geeqie-2.4.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+LUA_COMPAT=( lua5-{3,4} )
+
+inherit flag-o-matic lua-single meson optfeature xdg
+
+DESCRIPTION="A lightweight GTK image viewer forked from GQview"
+HOMEPAGE="http://www.geeqie.org"
+SRC_URI="https://github.com/BestImageViewer/${PN}/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~voyageur/distfiles/${P}-docs.tar.xz"
+# Doc build:
+# clone git at matching tag
+# mkdir build; ./gen_changelog.sh . build;
+# pandoc README.md -o build/README.html
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="debug djvu exif ffmpegthumbnailer heif jpeg jpeg2k jpegxl lcms lua map pdf raw spell tiff webp xmp zip"
+
+RDEPEND="gnome-extra/zenity
+ virtual/libintl
+ x11-libs/gtk+:3
+ djvu? ( app-text/djvu )
+ exif? ( >=media-gfx/exiv2-0.17:=[xmp?] )
+ ffmpegthumbnailer? ( media-video/ffmpegthumbnailer )
+ heif? ( >=media-libs/libheif-1.3.2 )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0:2= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpegxl? ( >=media-libs/libjxl-0.3.7:= )
+ lcms? ( media-libs/lcms:2 )
+ lua? ( ${LUA_DEPS} )
+ map? ( media-libs/clutter-gtk
+ media-libs/libchamplain:0.12[gtk] )
+ pdf? ( >=app-text/poppler-0.62[cairo] )
+ raw? ( >=media-libs/libraw-0.20:= )
+ spell? ( app-text/gspell )
+ tiff? ( media-libs/tiff:= )
+ webp? ( gui-libs/gdk-pixbuf-loader-webp:= )
+ zip? ( >=app-arch/libarchive-3.4.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ || ( dev-util/xxdi app-editors/vim-core )
+ dev-util/glib-utils
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.3-test-ancillary.patch )
+
+pkg_setup() {
+ # Do not require setting LUA_SINGLE_TARGET if lua is not used
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Disable doc build - not useful most of the time per upstream
+ sed -e "/subdir('doc')/d" -i meson.build || die
+}
+
+src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/585432
+ # https://github.com/BestImageViewer/geeqie/issues/1270
+ filter-lto
+
+ local emesonargs=(
+ -Dgq_helpdir="share/doc/${PF}"
+ -Dgq_htmldir="share/doc/${PF}/html"
+ $(meson_use debug)
+ $(meson_feature djvu)
+ $(meson_feature exif exiv2)
+ $(meson_feature ffmpegthumbnailer videothumbnailer)
+ $(meson_feature heif)
+ $(meson_feature jpeg)
+ $(meson_feature jpeg2k j2k)
+ $(meson_feature jpegxl)
+ $(meson_feature lcms cms)
+ $(meson_feature lua)
+ $(meson_feature map gps-map)
+ $(meson_feature pdf)
+ $(meson_feature raw libraw)
+ $(meson_feature spell)
+ $(meson_feature tiff)
+ $(meson_feature zip archive)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Manually generated ChangeLog
+ dodoc "${WORKDIR}"/${P}-docs/*
+
+ # The application needs access to some uncompressed doc files.
+ docompress -x /usr/share/doc/${PF}/AUTHORS
+ docompress -x /usr/share/doc/${PF}/ChangeLog
+ docompress -x /usr/share/doc/${PF}/README.md
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "Camera import and tethered photography plugins" media-gfx/gphoto2
+ optfeature "Lens ID plugin" media-libs/exiftool
+ optfeature "Image crop plugin" "media-libs/exiftool media-gfx/imagemagick"
+ optfeature "Image rotate plugin (JPEG)" media-gfx/fbida
+ optfeature "Image rotate plugin (TIFF/PNG)" media-gfx/imagemagick
+ optfeature "Print preview functionality" app-text/evince
+}