summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-11 10:12:31 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-11 10:12:44 +0000
commit20a697ec94dd5f167b50a970bba0bffccbd70775 (patch)
tree824e454f140da5ef71975eb5125a2679be7310bf /media-gfx
parentdev-python/watchdog: Bump to 2.0.0 (diff)
downloadgentoo-20a697ec94dd5f167b50a970bba0bffccbd70775.tar.gz
gentoo-20a697ec94dd5f167b50a970bba0bffccbd70775.tar.bz2
gentoo-20a697ec94dd5f167b50a970bba0bffccbd70775.zip
media-gfx/fotoxx: tweak for gcc-11
Reported-by: Kobboi Closes: https://bugs.gentoo.org/768207 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotoxx/files/fotoxx-15.05-docdir.patch (renamed from media-gfx/fotoxx/files/fotoxx-15.05.patch)1
-rw-r--r--media-gfx/fotoxx/files/fotoxx-15.05-gcc-11.patch31
-rw-r--r--media-gfx/fotoxx/fotoxx-15.05.ebuild7
3 files changed, 36 insertions, 3 deletions
diff --git a/media-gfx/fotoxx/files/fotoxx-15.05.patch b/media-gfx/fotoxx/files/fotoxx-15.05-docdir.patch
index 15fdaa9abacf..8cab49ff51ea 100644
--- a/media-gfx/fotoxx/files/fotoxx-15.05.patch
+++ b/media-gfx/fotoxx/files/fotoxx-15.05-docdir.patch
@@ -1,4 +1,3 @@
-diff -r -U1 fotoxx-14.10.2.orig/Makefile fotoxx-14.10.2/Makefile
--- fotoxx-14.10.2.orig/Makefile 2014-10-09 15:17:09.000000000 +0700
+++ fotoxx-14.10.2/Makefile 2014-10-13 20:44:55.061728475 +0700
@@ -16,3 +16,3 @@
diff --git a/media-gfx/fotoxx/files/fotoxx-15.05-gcc-11.patch b/media-gfx/fotoxx/files/fotoxx-15.05-gcc-11.patch
new file mode 100644
index 000000000000..5d84e687d397
--- /dev/null
+++ b/media-gfx/fotoxx/files/fotoxx-15.05-gcc-11.patch
@@ -0,0 +1,31 @@
+Fix 'smart_erase_blur' declaration and definition mismatch.
+
+https://bugs.gentoo.org/768207
+--- a/f.repair.cc
++++ b/f.repair.cc
+@@ -2265,7 +2265,7 @@ void smart_erase_func(int mode)
+
+ // add blur to the erased area to help mask the side-effects
+
+-int smart_erase_blur(float radius)
++void smart_erase_blur(float radius)
+ {
+ int ii, px, py, dx, dy, adx, ady;
+ float blur_weight[12][12]; // up to blur radius = 10
+@@ -2274,7 +2274,7 @@ int smart_erase_blur(float radius)
+ float red, green, blue;
+ float *pix9, *pix3, *pixN;
+
+- if (sa_stat != 3) return 0;
++ if (sa_stat != 3) return;
+
+ rad = radius - 0.2;
+ rad2 = rad * rad;
+@@ -2342,7 +2342,6 @@ int smart_erase_blur(float radius)
+ CEF->Fmods++;
+ CEF->Fsaved = 0;
+ Fpaint2(); // update window
+- return 0;
+ }
+
+
diff --git a/media-gfx/fotoxx/fotoxx-15.05.ebuild b/media-gfx/fotoxx/fotoxx-15.05.ebuild
index b0b0b1e02756..b15710b39828 100644
--- a/media-gfx/fotoxx/fotoxx-15.05.ebuild
+++ b/media-gfx/fotoxx/fotoxx-15.05.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,7 +25,10 @@ RDEPEND="${DEPEND}
media-libs/exiftool
x11-misc/xdg-utils"
-PATCHES=( "${FILESDIR}"/${P}.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-docdir.patch
+ "${FILESDIR}"/${P}-gcc-11.patch
+)
src_compile() {
tc-export CXX