summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-04-12 03:29:27 +0300
committerMart Raudsepp <leio@gentoo.org>2017-04-12 03:29:28 +0300
commit6dbd2cf969f4b34c1bb33a38e33984e1e6e1567d (patch)
tree2aaa756bb545a0e70f45863f9d626d02d398e702 /media-gfx/shotwell
parentmedia-gfx/postr: update twisted deps (diff)
downloadgentoo-6dbd2cf969f4b34c1bb33a38e33984e1e6e1567d.tar.gz
gentoo-6dbd2cf969f4b34c1bb33a38e33984e1e6e1567d.tar.bz2
gentoo-6dbd2cf969f4b34c1bb33a38e33984e1e6e1567d.zip
media-gfx/shotwell: bump to 0.24.6
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.24.6.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 8891e4bd498b..e756e0f191a4 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,2 +1,3 @@
DIST shotwell-0.24.3.tar.xz 5359588 SHA256 9b8fb84c70cef67fe3763b176a1d310b004cdc75036dd3ff4826dd5d120f425b SHA512 ca76310a59ffdcf02cec27b221cdad8ddb33911ae7f96e9331097dcd006ea7d64e0b9655f042f7661d1234c8a188e6c0fe2bde82f96dc4667b8f4773b90e7b60 WHIRLPOOL db49c212a4131f65a33d082de6b0d89ac396b35c1b759fa7cc702e3c3cf02d48d65c196ff3680424a63787ef61bb1da8838a521b1bc200242cca32bb290b7057
+DIST shotwell-0.24.6.tar.xz 5401300 SHA256 ecbbe8be422f0a228eb5a9d42f948f14d0b4ad4206dd503e3438be589595f947 SHA512 48f4595950700b3d193b7d73d4ff45abda1544de66c6252fcf98e94e58f284a0491b08d11045a96b8581f3370d759346739d3da1ef85311717908c33ab1c25c6 WHIRLPOOL a3f1127eb24ede554ccc1c08402aceb008728dff8ada56831f51729ae324f8c0bc425e6b04d210bd830ed3ce337a6805aef59f9d9bb9d7354127942c6794d141
DIST shotwell-0.25.0.1.tar.xz 5398404 SHA256 e69c96b3ee650aed8f83dfe099e01d85f83ab19f56995a90d48681fdf26400a6 SHA512 6a071b0b7d84bf78727b84e0ba707d6d7f5408a0b942962771b24a79381c102c58c06b4895eba69527215103279946f4e33b14410a1ce6dd58d3dba3870975df WHIRLPOOL 7ab54b4b28d1db631e9a359ab803a6a4447a6642b44daf59ed4970e49ee40cf23208f7bf0754eaccfa6ed10ad4b3f02110769dad4f32ff13b1173f636c4d6b62
diff --git a/media-gfx/shotwell/shotwell-0.24.6.ebuild b/media-gfx/shotwell/shotwell-0.24.6.ebuild
new file mode 100644
index 000000000000..a85efadc853d
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.24.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 multilib toolchain-funcs vala versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/glib-2.30.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.8.5:0.8
+ >=dev-libs/libxml2-2.6.32:2
+ gnome-base/dconf
+ >=media-libs/gexiv2-0.4.90
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16:=
+ >=media-libs/libgphoto2-2.5:=
+ >=media-libs/libraw-0.13.2:=
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ >=net-libs/libsoup-2.26.0:2.4
+ net-libs/webkit-gtk:4
+ virtual/libgudev:=[introspection]
+ >=x11-libs/gtk+-3.12.2:3[X]
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ >=sys-devel/m4-1.4.13
+ virtual/pkgconfig
+"
+
+# This probably comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/libexec/${PN}/${PN}-video-thumbnailer"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}