summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-07 14:44:56 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-07 14:47:02 +0100
commit114e21530584ed0c12ca9abf5c3ffd66809cc26a (patch)
tree0fc6532d4d9e8825a3a5911242c468d95e485e6c /media-gfx/scour
parentapp-portage/fetchcommandwrapper: 0.8.2 + SRC_URI move (diff)
downloadgentoo-114e21530584ed0c12ca9abf5c3ffd66809cc26a.tar.gz
gentoo-114e21530584ed0c12ca9abf5c3ffd66809cc26a.tar.bz2
gentoo-114e21530584ed0c12ca9abf5c3ffd66809cc26a.zip
media-gfx/scour-0.36-r1: added python3_7 + eapi7
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx/scour')
-rw-r--r--media-gfx/scour/scour-0.36-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/scour/scour-0.36-r1.ebuild b/media-gfx/scour/scour-0.36-r1.ebuild
new file mode 100644
index 000000000000..8997eb6dcf04
--- /dev/null
+++ b/media-gfx/scour/scour-0.36-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Take an SVG file and produce a cleaner and more concise file"
+HOMEPAGE="https://github.com/scour-project/scour"
+SRC_URI="https://github.com/scour-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" testscour.py -v || die "Tests fail with ${EPYTHON}"
+}